
  



<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.argus-press.com/content/tncms/live/" />
<meta name="keywords" content="owosso, news_local" />
<meta name="news_keywords" content="owosso, news_local" />
<meta name="description" content="OWOSSO &mdash; The Shiawassee Prevention Network is hosting a prescription Drug Take Back event, according to a press release from the organization." />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/bdf824b4-27a0-11e8-a78f-67fc2c3cc6dd.png" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Drug disposal event slated" />
<meta property="og:description" content="OWOSSO &mdash; The Shiawassee Prevention Network is hosting a prescription Drug Take Back event, according to a press release from the organization." />
<meta property="og:site_name" content="The Argus-Press" />
<meta property="og:section" content="Owosso" />
<meta property="fb:app_id" content="140096299389133" />
<meta property="article:publisher" content="https://www.facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@arguspress" />
<meta property="tncms:subs" content="2.0" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.c82aec58b25786d9065c7ecf4b19c25f.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,600,700"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/news\/community\/owosso","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":480},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"aad77431-3d48-5e65-b7c2-ce6cb58f3772","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "851,890,2611,2612", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/impressions.js?_dc=1617125704"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/traffic.js?_dc=1617078902"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/settings.js?_dc=1575559551"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-impact-top/1.js?_dc=1587655847"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1607693804"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-middle-asset/1.js?_dc=1607693804"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-bottom-asset/1.js?_dc=1595359709"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"#FFFFFF","list_ids":"cb376124-e497-11e5-aa65-0323eecfec65, cadc77e8-d4f5-11e5-8631-5fa74c5b78b4","require_user_account":"1","signup_lists_only":"","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","text_color":"inherit","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_select_all":"","show_audience":"","hide_audience":"","block_id":"1546640"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1598446490"></script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661","asset_id":"bc0a883e-9153-11eb-80ad-df3790e3ef9e","title":"Are Republican efforts to change election laws justified?","url":"\/poll_bc0a883e-9153-11eb-80ad-df3790e3ef9e.html","results":"https:\/\/www.argus-press.com\/poll_bc0a883e-9153-11eb-80ad-df3790e3ef9e.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-bottom/1.js?_dc=1573153089"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Drug disposal event slated | Owosso | argus-press.com</title>
            
    <style>body { background-color: #eeeeee; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #252525; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #eeeeee; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #eee; } .fixed-nav #main-navigation { background-color: #eee !important; } #site-top-nav-container, #site-top-nav { background-color: #000; } #site-footer-container, #site-footer { background-color: #252525; color: #fff; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000; } .navbar-toggle .icon-bar { background-color: #000 !important; } .navbar-toggle .sr-only-show { color: #000 !important; } #site-top-nav .list-inline>li>a { color: #fff; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #eee; }/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000; } }#site-copyright a, #site-footer a { color: #fff; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /************** Variables --------------- These variables control the colors of the buttons. If changing the colors of buttons, change the color here rather than in the actual css. ***************/ body {font-family:'Open Sans', sans-serif;} .btn {transition:all .25s ease-in-out;} .btn-default {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37); color:#fff!important;} .btn-default:hover, .btn-default:focus {background-color:rgb(136, 21, 24); border-color:rgb(136, 21, 24);} .btn-primary {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .btn-primary:hover, .btn-primary:focus {background-color:rgb(136, 21, 24); border-color:rgb(136, 21, 24);} .btn-warning {background-color:#FFCE34; border-color:#FFCE34;} .btn-warning:hover, .btn-warning:focus {background-color:#D8B02B; border-color:#D8B02B;} .btn-success {background-color:#275B33; border-color:#275B33;} .btn-success:hover, .btn-success:focus {background-color:#1F4929; border-color:#1F4929;} .btn-danger {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .btn-danger:hover, .btn-danger:focus {background-color:rgb(136, 21, 24); border-color:rgb(136, 21, 24);} .label-primary {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .label-warning {background-color:#FFCE34; border-color:#FFCE34;} .label-success {background-color:#275B33; border-color:#275B33;} .label-danger {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .nav-pills>li.active>a, .nav-pills>li.active>a:focus, .nav-pills>li.active>a:hover {background-color:rgb(136, 21, 24);} .progress-bar {background-color:#275B33;} /* HEADER */ #topbar-col-two-nav_menu {text-align:right;} #site-header {padding-bottom:0px;} #site-header > .row:nth-child(2) {padding:10px 0; background:rgb(169, 33, 37); background:linear-gradient(rgb(136, 21, 24), rgb(169, 33, 37));} #masthead-col-one, #masthead-col-two {width:50%;} #navbar-collapse > .pull-right {max-width:30%;} #navbar-collapse > .pull-right .search-form-container {margin:7px 10px!important;} #main-nav_menu > li > a {font-family:'Open Sans', sans-serif; text-transform:uppercase; font-weight:700;} #site-navbar-container .navbar-static .navbar-nav>li>a {border-right:1px solid rgba(255,255,255,.05);} #site-search-1545725-dropdown .dropdown-toggle {margin-top:5px; color:#fff;} #site-search-1545725-dropdown .dropdown-menu {left:0;} #user-controls-1545729 {padding-top:10px;} #blox-ad-position-fixed-impact-top1 {min-height:90px;} #blox-ad-position-fixed-impact-top1 .tnt-expandable-small {min-height:90px;} #blox-ad-position-fixed-impact-top1 .tnt-expandable-small img {position:fixed; top:0; z-index:9999;} #site-search-1545725-dropdown .dropdown-menu {padding: 15px; width: 250px; font-weight: normal;} /* BODY */ .block-title-inner * {font-family:'Open Sans', sans-serif; text-transform:uppercase; font-weight:700;} #tncms-block-1545679 .block, #tncms-block-1545679 .heading {margin-bottom:0!important;} /* Dynamic Block title */ #tncms-block-1545679 .heading a {text-decoration:none!important} /* Dynamic Block title */ .card-headline a {font-weight:600;} .search-form-container, .panel-default>.panel-heading {background-color:rgba(37,37,37,0.06);} .subscription-service.panel-default>.service-heading {background:#252525;} .most-popular .tab-content {background:#fff;} .subscription .modal-body a {color:white!important;} .subscription .modal-body .no-services a {color:white; padding:5px 10px; display:inline-block; border-radius:3px; background-color:rgb(169, 33, 37); transition:all .3s;} .subscription .modal-body .no-services a:hover {background-color:rgb(136, 21, 24); text-decoration:none;} .form-category-forms h4 {font-size:2em;} .form-category-forms a {font-size:1.2em; line-height:2em;} .featured-photos .image {max-height:500px;} @media (max-width:991px) { button.hamburger-desktop.navbar-toggle.pull-left {display:none;} #main-navigation {height:65px; background:rgb(169, 33, 37); background:linear-gradient(rgb(136, 21, 24), rgb(169, 33, 37));} .navbar-brand img {max-height:45px;} .navbar-toggle .icon-bar {background:#fff!important;} } @media (max-width:350px) { #main-navigation {height:50px;} .navbar-brand img {max-height:30px;} } /* iPhone 5 ----------- */ @media only screen and (min-device-width: 320px) and (max-device-height:568px) and (orientation: landscape) { .tnt-ads { padding-bottom: 12px; } } @media only screen and (min-device-width: 320px) and (max-device-height: 568px) and (orientation: portrait) { .tnt-ads { padding-bottom: 12px; } } /* jsandy #678250 */ #blox-ad-position-fixed-impact-top1 {min-height: 1px;} .tncms-region-ads div:first-child, .tnt-ads, .tnt-ads-container div:first-child {margin-bottom: 20px;} @media screen and (max-width: 970px) { #blox-ad-position-fixed-impact-top1 {display: none;} } @media (max-width: 991px) { #main-navigation { height: 85px; } } </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.argus-press.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Drug disposal event slated | Owosso | argus-press.com" href="http://www.argus-press.com/search/?f=rss&amp;t=article&amp;c=news/community/owosso&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-aad77431-3d48-5e65-b7c2-ce6cb58f3772  section-news section-community section-owosso type-article infinity-disabled" data-path="/news/community/owosso">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.argus-press.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=boxy&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Fcommunity%2Fowosso&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=480&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=aad77431-3d48-5e65-b7c2-ce6cb58f3772&amp;tncms.asset.app=editorial&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.argus-press.com",
  secureDomain: "argus-press.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        

    
<div id="template-metering" data-message-mode="subscription-wall">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!

                </h4>
                <p>Please <span class="not-logged-in">log in, or sign up for a new account and</span> purchase a subscription to continue reading.</p>

                <div class="col-xs-12">
                    <div class="row not-logged-in">

                        <div class="col-xs-6">
                            
    <a  class="btn btn-default btn-block" href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">Sign Up</a>
                        </div>
                        <div class="col-xs-6">
                            
    <a class="btn btn-primary btn-block" href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">Log In</a>
                        </div>
                    </div>
                    <div class="row logged-in">
                        <div class="pull-right">
                            <a class="btn btn-default meter-modal-open">Purchase a Subscription
</a>
                        </div>
                    </div>
                    </div>
            </div>
        </div>
        </div>
    
    
</template>
    
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="blox modal subscription">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Thank you for reading!
</h4>
            </div>

            <div class="modal-body">
                <div class="row">
                    <div class="col-xs-12">
                    <div class="not-logged-in">
                            <p>Please log in, or sign up for a new account and purchase a subscription to continue reading.
</p>
                        </div>
            
                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Please purchase a subscription to continue reading.
</p>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.
</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    
    <a  class="btn btn-default btn-block" href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">Sign Up</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-primary btn-block" href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">Log In</a>
                                </div>
                            </div>
                        </div>
                    <div class="col-xs-12">
                            </div>
                        
                        <div class="col-xs-12 logged-in">
                            <div class="subscription-services">
    <script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[851] = {
    'name':'Online Paywall Access',
    'id':'851',
    'prices':['200','750','2250','4500','9000'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<div data-service-id="851" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Online Paywall Access</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>Please purchase an Online Pass to gain access to our Online Content.</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            <span class="text-muted">Starting at</span><div class="service-price-text">
                                    $2.00
                                    
                                        
for 1 day

                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="851" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.argus-press.com/users/admin/service/purchase/?serviceid=851&referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
            <div class="panel-footer">
                <div class="view-rates-container">
                    <a class="view-rates-link" data-toggle="collapse" href="#collapse-rates-851">
                        <span class="view-rates-text">View all rates</span> <i class="fas tnt-caret-down"></i>
                    </a>
                </div>
                <div id="collapse-rates-851" class="collapse collapse-rates">
                    <table class="table table-striped table-condensed">
                        <thead>
                            <tr>
                                <th>Rate</th>
                                <th>Price</th>
                                <th>Duration</th>
                            </tr>
                        </thead>
                        <tbody>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">One Day Access</td>
                                    <td class="service-rate-cell-price">
                                        $2.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 1 day
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">One Month Access - 30 days</td>
                                    <td class="service-rate-cell-price">
                                        $7.50
                                    </td>
                                    <td class="service-rate-cell-duration">
for 30 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Three Month Access - 90 days</td>
                                    <td class="service-rate-cell-price">
                                        $22.50
                                    </td>
                                    <td class="service-rate-cell-duration">
for 90 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Six Month Access - 180 days</td>
                                    <td class="service-rate-cell-price">
                                        $45.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 180 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">One Year Access - 365 days</td>
                                    <td class="service-rate-cell-price">
                                        $90.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 365 days
</td>
                                </tr>
                            
                        </tbody>
                    </table>
                </div>
            </div>
        
    </div><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[890] = {
    'name':'Print Subscribers Registration for Access',
    'id':'890',
    'prices':[''],
    'brand':'csv',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<div data-service-id="890" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Print Subscribers Registration for Access</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>Online Access for Print Subscribers. &nbsp;Do you have a print subscription with the Argus-Press? If yes, then click here to enjoy complimentary access to our Online Content!</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            
                                <div class="service-price-text">
                                    Free
                                    
                                        access for current print subscribers
                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="890" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.argus-press.com/users/admin/service/purchase/?serviceid=890&referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
    </div>

    
</div>

<script>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</script>

</div>
                        
                    </div>
                </div>
            </div>
            <div class="modal-footer">
                <div class="logged-in">
                <form id="service-promo-open" class="text-left service-promo-open" method="post" action="">
    <input type="hidden" name="serviceid" value=""/>
    <div class="form-group">
        <label for="promo">Have a promo code?</label>
    </div>
    
    <div class="form-group">
        <div class="input-group">
        <input type="text" class="form-control" name="promo" placeholder="Enter Code" value=""/>
        <span class="input-group-btn">
        <button type="submit" class="btn btn-primary">Find Offers</button>
        </span>
        </div>
    </div>
</form>
                </div>
                
            </div>
        </div>
    </div>
</div>

<script>
var promoOpenedFromModal = false;
$(function(){
    $('#service-promo-open').on('submit',function(){
    
        if($('#service-promo-open').find('input[name=promo]').val()!=""){
            $('#service-promo-modal').find('input[name=promo]').val($('#service-promo-open').find('input[name=promo]').val());
            $('#service-promo-modal').find('.promo-loading').show();
    
            if($('#subscription-modal').is(':visible')){
                $('#subscription-modal').modal('toggle');
                promoOpenedFromModal = true;
                setTimeout(function () {
                    $('#service-promo-modal').find('.modal').modal('toggle').submit();
                },500);
            }else{
                $('#service-promo-modal').find('.modal').modal('toggle').submit();
            }
       }
    
        return false;
    });
    
    if($("#service-promo-open").find("input[name=promo]").val()!=""){
        setTimeout(function () {
            $("#service-promo-open").find("button").click();
        },500);
    }
    
});
</script>

<form id="service-promo-modal" class="" method="post" action="https://www.argus-press.com/content/tncms/live/" data-endpoint="https://www.argus-press.com/tncms/subscription/services/?promoCode=">
    <input type="hidden" name="serviceid" value=""/>
    <input type="hidden" name="referer_url" value="/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"/>

    <div class="modal fade">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                    <div class="form-group">
                        <label class="" for="promo">Have a promo code?</label>
                    </div>
                    <div class="form-group">
                        <div class="input-group">
                            <input type="text" class="form-control" name="promo" placeholder="Enter Code" value="">
                            <span class="input-group-btn"><button type="submit" class="btn btn-primary">Find Offers</button></span>
                        </div>
                    </div>
                </div>
                <div class="modal-body">
                    <template class="template promo-not-found-template">
                        <div class="promo-not-found-warning alert alert-warning">
    <p><strong>Sorry</strong>, no promotional deals were found matching that code.</p>
</div></template>
                    <template class="template promo-found-message-template">
                        <div class="promo-found-message alert alert-success clearfix">
    <p><strong>Promotional Rates</strong> were found for your code.
    
    </p>
</div></template>
                    <template class="template promo-error-template">
                        <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template>
                    
                    <div class="row">
                    <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div class="col-xs-12 service-promo-status-message"></div>
                    <div class="col-xs-12 output"></div>
                    </div>
                    
                    <template class="template-promo-service hide">
                        <div class="promotion-service subscription-service panel panel-default">
                            <h3 class="panel-heading"></h3>
                            <div class="panel-body">
                                <div class="service-note alert alert-info"></div>
                                <p class="description"></p>
                                <div class="rate-output"><p class="hide">do not remove</p></div>
                            </div>
                        </div>
                    </template>
                    <template class="template-promo-rate hide">
                        <div class="promotion subscription-service panel panel-default">
                            <div class="panel-body">
                                <h4 class="rate-name"></h4>
                                <div class="clearfix">
                                    <span class="pull-left">
                                        <div class="terms-automatic">
                                            <strong><span class="price"></span> <span class="duration"></span></strong>
                                            <small class="fine-print"></small>
                                        </div>
                                        <div class="terms-manual"></div>
                                    </span>
                                    <a data-subscription-service="" class="pull-right btn btn-primary rate-link">Get Started</a>
                                </div>
                            </div>
                        </div>
                    </template>

                </div>
                <div class="modal-footer">
                    <button type="button" class="btn btn-default pull-left" data-dismiss="modal">Back</button>
                </div>
            </div>
        </div>
    </div>
</form><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[851] = {
    'name':'Online Paywall Access',
    'id':'851',
    'prices':['200','750','2250','4500','9000'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[890] = {
    'name':'Print Subscribers Registration for Access',
    'id':'890',
    'prices':[''],
    'brand':'csv',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[2611] = {
    'name':'Free - Updated',
    'id':'2611',
    'prices':[''],
    'brand':'free',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[2612] = {
    'name':'argus-press.com',
    'id':'2612',
    'prices':[''],
    'brand':'domain',
    'category':'subscription',
    'list':'Article'
};
</script>
    
<script>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</script><script>

    $(function(){
        $('#service-promo-modal').on('submit',function(){
            var promoEl = $('#service-promo-modal');
            var promoVal = promoEl.find('input[name=promo]').val();
        
            __tnt.subscription.promos.fetch(promoEl, promoVal);
            
            $("#service-promo-modal").find("[data-dismiss=modal]").on('click',function(){
                if(promoOpenedFromModal){ 
                    $("#template-metering").find('.metering-modal').first().modal();
                    promoOpenedFromModal = true;
                }
            });

            return false;
        });
    });
</script>

<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
        $('#eedition-subscription').find('.meter-modal-open').on('click',function(){
            $("#template-metering").find('.metering-modal').first().modal();
        });
    });
    
</script>
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(851);
                
                bloxServiceIDs.push(890);
                
                bloxServiceIDs.push(2611);
                
                bloxServiceIDs.push(2612);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-impact-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-impact-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-impact-top', slot: 1, fold: "above"});</script>

</div>
</div>

        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.argus-press.com/tncms/admin/editorial-asset/?edit=aad77431-3d48-5e65-b7c2-ce6cb58f3772"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/nie.html"  class="nav-link tnt-section-newspapers-in-education">Newspapers in Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/subscribe"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-local-news">Local News</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-local-sports">Local Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/bancroft/"  class="nav-link tnt-section-bancroft">Bancroft</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/byron/"  class="nav-link tnt-section-byron">Byron</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/chesaning/"  class="nav-link tnt-section-chesaning">Chesaning</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/corunna/"  class="nav-link tnt-section-corunna">Corunna</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/durand/"  class="nav-link tnt-section-durand">Durand</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/elsie/"  class="nav-link tnt-section-elsie">Elsie</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/laingsburg/"  class="nav-link tnt-section-laingsburg">Laingsburg</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/lennon/"  class="nav-link tnt-section-lennon">Lennon</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/morrice/"  class="nav-link tnt-section-morrice">Morrice</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/new_lothrop/"  class="nav-link tnt-section-new-lothrop">New Lothrop</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/ovid/"  class="nav-link tnt-section-ovid">Ovid</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/owosso/"  class="nav-link tnt-section-owosso">Owosso</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/perry/"  class="nav-link tnt-section-perry">Perry</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/shiawassee_area/"  class="nav-link tnt-section-shiawassee-area">Shiawassee Area</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/vernon/"  class="nav-link tnt-section-vernon">Vernon</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters_to_editor">Letters_to_editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/letter"  class="nav-link tnt-section-submit-letter-to-the-editor">Submit Letter to the Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/staff_commentaries/"  class="nav-link tnt-section-staff_commentaries">Staff_commentaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_commentaries/"  class="nav-link tnt-section-guest_commentaries">Guest_commentaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/business"  class="nav-link tnt-section-local-business">Local Business</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/education"  class="nav-link tnt-section-education">Education</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/health"  class="nav-link tnt-section-health">Health</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/arts_and_entertainment/"  class="nav-link tnt-section-arts-entertainment">Arts & Entertainment</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/religion/"  class="nav-link tnt-section-religion">Religion</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/kids_korner/"  class="nav-link tnt-section-kids-korner">Kids Korner</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/farm_garden/"  class="nav-link tnt-section-farmgarden">Farm/Garden</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-14" data-target="#mobile-nav-left_menu-child-14">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/announcements/"  class="nav-link tnt-section-neighbors">Neighbors</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-14" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/announcements/anniversaries/"  class="nav-link tnt-section-anniversaries">Anniversaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/announcements/births/"  class="nav-link tnt-section-births">Births</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/announcements/engagements/"  class="nav-link tnt-section-engagements">Engagements</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/announcements/weddings/"  class="nav-link tnt-section-weddings">Weddings</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-15" data-target="#mobile-nav-left_menu-child-15">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/world_news/state_news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-15" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/world_news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/world_news/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/world_news/international/"  class="nav-link tnt-section-international">International</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-16" data-target="#mobile-nav-left_menu-child-16">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/sports/sports_local/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-16" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/international/"  class="nav-link tnt-section-international">International</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/weather"  class="nav-link tnt-section-weather">Weather</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-19" data-target="#mobile-nav-left_menu-child-19">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-19" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-search-listings">Search Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/job/"  class="nav-link tnt-section-job">Job</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/vehicle"  class="nav-link tnt-section-vehicle">Vehicle</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/"  class="nav-link tnt-section-housing">Housing</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/sale/pet"  class="nav-link tnt-section-pets">Pets</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/other"  class="nav-link tnt-section-miscellaneous">Miscellaneous</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="classifieds/housing/rent/apartment"  class="nav-link tnt-section-apartments">Apartments</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/legal_notices/"  class="nav-link tnt-section-legal-notices">Legal Notices</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-1545730" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1545730" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.argus-press.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1545730').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.argus-press.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.argus-press.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.argus-press.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1545730').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.argus-press.com/users/logout/" id="user-logout-form-1545730"><input type="hidden" name="referer_url" value="https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/nie.html"  class="nav-link tnt-section-newspapers-in-education">Newspapers in Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms"  class="nav-link tnt-section-online-forms">Online Forms</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news/news_local/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/news_local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/world_news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/world_news/national/"  class="nav-link tnt-section-national-news">National News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/world_news/international/"  class="nav-link tnt-section-international-news">International News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/sports/sports_local/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/by_school/"  class="nav-link tnt-section-by-school">By School</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/by_sport/"  class="nav-link tnt-section-by-sport">By Sport</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/sports_local/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/national/"  class="nav-link tnt-section-national-sports">National Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/international/"  class="nav-link tnt-section-international-sports">International Sports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters To The Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/letter"  class="nav-link tnt-section-submit-letter-to-editor">Submit Letter To Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/staff_commentaries/"  class="nav-link tnt-section-staff-commentaries">Staff Commentaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_commentaries/"  class="nav-link tnt-section-guest-commentaries">Guest Commentaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-search-listings">Search Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/job/"  class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/vehicle/"  class="nav-link tnt-section-cars">Cars</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/"  class="nav-link tnt-section-homes">Homes</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/sale/pet/"  class="nav-link tnt-section-pets">Pets</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/other/"  class="nav-link tnt-section-miscellaneous">Miscellaneous</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/rent/apartment/"  class="nav-link tnt-section-apartments">Apartments</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-more">More</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/business"  class="nav-link tnt-section-local-business">Local Business</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/education"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/health"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_entertainment/"  class="nav-link tnt-section-arts-entertainment">Arts & Entertainment</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/religion/"  class="nav-link tnt-section-religion">Religion</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/kids_korner/"  class="nav-link tnt-section-kids-korner">Kids Korner</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/farm_garden/"  class="nav-link tnt-section-farm-garden">Farm Garden</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/announcements/"  class="nav-link tnt-section-neighbors">Neighbors</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather"  class="nav-link tnt-section-weather">Weather</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/legal_notices/"  class="nav-link tnt-section-legal-notices">Legal Notices</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-1545726" class="tncms-block hidden-md hidden-lg"><section id="block-1545726" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1545726" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1545726" aria-labelledby="site-search-button-1545726" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-1545726-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1545726-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1545726-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1545726').submit();
        return false;
    });

    $('#site-search-1545726').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1545726 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1545726 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1545726-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1545725" class="tncms-block padding-right padding-left pull-left"><ul id="site-search-1545725-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1545725" aria-labelledby="site-search-button-1545725" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-1545725-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1545725-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1545725" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1545725-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1545725').submit();
        return false;
    });

    $('#site-search-1545725').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1545725 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1545725 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1545725-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1545727" class="tncms-block padding-left padding-right pull-left"><div class="follow-links-1545727 default">
    
    <section id="block-1545727" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/arguspress/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.argus-press.com",
  "sameAs" : ["https://www.facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846","http://twitter.com/arguspress/"]
}
</script>
<div class="clearfix"></div></div></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-two-nav" class="tncms-region-nav"><ul id="topbar-col-two-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/subscribe"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-online-forms"  href="/site/forms"  tabindex="0">
                    <span class="nav-label">Online Forms</span>
                </a></li></ul></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-1545618" class="tncms-block hidden-xs hidden-sm col-md-8 col-lg-9">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546652" class="tncms-block hidden-xs hidden-sm col-md-4 col-lg-3">
        <div id="blox-ad-position-block-tile-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-top","slot":"1","fold":"above","width":"200","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1545677" class="tncms-block"><section id="block-1545677" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=150%2C34 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=200%2C45 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=225%2C51 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=300%2C68 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=400%2C91 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=540%2C123 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=640%2C146 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=750%2C171 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=990%2C225 990w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=1035%2C235 1035w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=1200%2C273 1200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=1333%2C303 1333w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=1476%2C336 1476w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png 2008w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1609"
                height="366"
                alt="Argus-Press"></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1556880" class="tncms-block padding-bottom"><!--
Author: Tim Smith
-->
<style>
.date {color:#fff; font-weight:bold;}
@media (min-width:992px){
.date {text-align:right;}
}
</style>

<p class="date"></p>

<script>
var d=new Date();

var weekday = new Array(7);
weekday[0] =  "Sunday";
weekday[1] = "Monday";
weekday[2] = "Tuesday";
weekday[3] = "Wednesday";
weekday[4] = "Thursday";
weekday[5] = "Friday";
weekday[6] = "Saturday";

var n = weekday[d.getDay()];

var month = new Array();
month[0] = "January";
month[1] = "February";
month[2] = "March";
month[3] = "April";
month[4] = "May";
month[5] = "June";
month[6] = "July";
month[7] = "August";
month[8] = "September";
month[9] = "October";
month[10] = "November";
month[11] = "December";
var m = month[d.getMonth()];

var date = d.getDate();
var year = d.getFullYear();

function addZero(i) {
    if (i < 10) {
        i = "0" + i;
    }
    else if (i > 12) {
        i = i - 12;
    }
    return i;
}

    var h = addZero(d.getHours());
    var min = addZero(d.getMinutes());
    var ampm;
    if (d.getHours() > 12) {
    	ampm = "PM";
    }
    else {
    	ampm = "AM";
    }
    var time = h + ":" + min + " " + ampm;


/*$(".date").text(n + ", " + m + " " + date + ", " + year + " " + time);*/
$(".date").text(`${m} ${date} ${year}`);
    
</script></div><div id="tncms-block-1545731" class="tncms-block"><div id="weather-1545731" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=48867" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-sunny-overcast"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">65&deg;</span>
                    
                        <span class="cond">Fair/Wind <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="48867"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1545731 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Owosso, MI
                                
                                 <small>(48867)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Windy with a mix of clouds and sun. High 68F. Winds SW at 20 to 30 mph.  Winds could occasionally gust over 40 mph..</p>
                            <h5>Tonight</h5>
                            <p>A steady rain this evening. Showers continuing overnight. Low 36F. Winds W at 10 to 15 mph. Chance of rain 70%.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: March 30, 2021 @ 1:34 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=48867"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop  navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                         
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1545722" class="tncms-block"><section id="block-1545722" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=150%2C34 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=200%2C45 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=225%2C51 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=300%2C68 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=400%2C91 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=540%2C123 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=640%2C146 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=750%2C171 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=990%2C225 990w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=1035%2C235 1035w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=1200%2C273 1200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=1333%2C303 1333w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=1476%2C336 1476w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png 2008w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1609"
                height="366"
                alt="Argus-Press"></a></div></section></div><div id="tncms-block-1642447" class="tncms-block padding-bottom hidden-lg hidden-md"><!--
Author: Tim Smith
-->
<style>
.date {color:#fff; font-weight:bold;}
@media (min-width:992px){
.date {text-align:right;}
}
</style>

<p class="date"></p>

<script>
var d=new Date();

var weekday = new Array(7);
weekday[0] =  "Sunday";
weekday[1] = "Monday";
weekday[2] = "Tuesday";
weekday[3] = "Wednesday";
weekday[4] = "Thursday";
weekday[5] = "Friday";
weekday[6] = "Saturday";

var n = weekday[d.getDay()];

var month = new Array();
month[0] = "January";
month[1] = "February";
month[2] = "March";
month[3] = "April";
month[4] = "May";
month[5] = "June";
month[6] = "July";
month[7] = "August";
month[8] = "September";
month[9] = "October";
month[10] = "November";
month[11] = "December";
var m = month[d.getMonth()];

var date = d.getDate();
var year = d.getFullYear();

function addZero(i) {
    if (i < 10) {
        i = "0" + i;
    }
    else if (i > 12) {
        i = i - 12;
    }
    return i;
}

    var h = addZero(d.getHours());
    var min = addZero(d.getMinutes());
    var ampm;
    if (d.getHours() > 12) {
    	ampm = "PM";
    }
    else {
    	ampm = "AM";
    }
    var time = h + ":" + min + " " + ampm;


/*$(".date").text(n + ", " + m + " " + date + ", " + year + " " + time);*/
$(".date").text(`${m} ${date} ${year}`);
    
</script></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1545729" class="tncms-block"><div id="user-controls-1545729" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.argus-press.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1545729').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.argus-press.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.argus-press.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.argus-press.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1545729').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.argus-press.com/users/logout/" id="user-logout-form-1545729"><input type="hidden" name="referer_url" value="https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-newspapers-in-education"  href="/site/nie.html"  tabindex="0">
                    <span class="nav-label">Newspapers in Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-online-forms"  href="/site/forms"  tabindex="0">
                    <span class="nav-label">Online Forms</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/news_local/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-local-news"  href="/news/news_local/"  tabindex="0">
                    <span class="nav-label">Local News</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/news/community/"  tabindex="0">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-2-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-owosso"  href="/news/community/owosso/"  tabindex="0">
                    <span class="nav-label">Owosso</span>
                </a></li><li>
                <a class="nav-link   tnt-section-corunna"  href="/news/community/corunna/"  tabindex="0">
                    <span class="nav-label">Corunna</span>
                </a></li><li>
                <a class="nav-link   tnt-section-durand"  href="/news/community/durand/"  tabindex="0">
                    <span class="nav-label">Durand</span>
                </a></li><li>
                <a class="nav-link   tnt-section-perry"  href="/news/community/perry/"  tabindex="0">
                    <span class="nav-label">Perry</span>
                </a></li><li>
                <a class="nav-link   tnt-section-morrice"  href="/news/community/morrice/"  tabindex="0">
                    <span class="nav-label">Morrice</span>
                </a></li><li>
                <a class="nav-link   tnt-section-new-lothrop"  href="/news/community/new_lothrop/"  tabindex="0">
                    <span class="nav-label">New Lothrop</span>
                </a></li><li>
                <a class="nav-link   tnt-section-byron"  href="/news/community/byron/"  tabindex="0">
                    <span class="nav-label">Byron</span>
                </a></li><li>
                <a class="nav-link   tnt-section-laingsburg"  href="/news/community/laingsburg/"  tabindex="0">
                    <span class="nav-label">Laingsburg</span>
                </a></li><li>
                <a class="nav-link   tnt-section-shiawassee-area"  href="/news/community/shiawassee_area/"  tabindex="0">
                    <span class="nav-label">Shiawassee Area</span>
                </a></li><li>
                <a class="nav-link   tnt-section-chesaning"  href="/news/community/chesaning/"  tabindex="0">
                    <span class="nav-label">Chesaning</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ovid"  href="/news/community/ovid/"  tabindex="0">
                    <span class="nav-label">Ovid</span>
                </a></li><li>
                <a class="nav-link   tnt-section-elsie"  href="/news/community/elsie/"  tabindex="0">
                    <span class="nav-label">Elsie</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-state-news"  href="/world_news/state_news/"  tabindex="0">
                    <span class="nav-label">State News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-national-news"  href="/world_news/national/"  tabindex="0">
                    <span class="nav-label">National News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-international-news"  href="/world_news/international/"  tabindex="0">
                    <span class="nav-label">International News</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/sports_local/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu" ><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-by-school"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/by_school/"  tabindex="0">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">By School</span>
                </a><ul id="main-nav_menu-child-3-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-byron"  href="/sports/by_school/byron/"  tabindex="0">
                    <span class="nav-label">byron</span>
                </a></li><li>
                <a class="nav-link   tnt-section-chesaning"  href="/sports/by_school/chesaning/"  tabindex="0">
                    <span class="nav-label">chesaning</span>
                </a></li><li>
                <a class="nav-link   tnt-section-corunna"  href="/sports/by_school/corunna/"  tabindex="0">
                    <span class="nav-label">corunna</span>
                </a></li><li>
                <a class="nav-link   tnt-section-durand"  href="/sports/by_school/durand/"  tabindex="0">
                    <span class="nav-label">durand</span>
                </a></li><li>
                <a class="nav-link   tnt-section-laingsburg"  href="/sports/by_school/laingsburg/"  tabindex="0">
                    <span class="nav-label">laingsburg</span>
                </a></li><li>
                <a class="nav-link   tnt-section-morrice"  href="/sports/by_school/morrice/"  tabindex="0">
                    <span class="nav-label">morrice</span>
                </a></li><li>
                <a class="nav-link   tnt-section-new_lothrop"  href="/sports/by_school/new_lothrop/"  tabindex="0">
                    <span class="nav-label">new_lothrop</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ovid-elsie"  href="/sports/by_school/ovid-elsie/"  tabindex="0">
                    <span class="nav-label">ovid-elsie</span>
                </a></li><li>
                <a class="nav-link   tnt-section-owosso"  href="/sports/by_school/owosso/"  tabindex="0">
                    <span class="nav-label">owosso</span>
                </a></li><li>
                <a class="nav-link   tnt-section-perry"  href="/sports/by_school/perry/"  tabindex="0">
                    <span class="nav-label">perry</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-by-sport"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/by_sport/"  tabindex="0">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">By Sport</span>
                </a><ul id="main-nav_menu-child-3-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-auto_racing"  href="/sports/by_sport/auto_racing/"  tabindex="0">
                    <span class="nav-label">auto_racing</span>
                </a></li><li>
                <a class="nav-link   tnt-section-baseball"  href="/sports/by_sport/baseball/"  tabindex="0">
                    <span class="nav-label">baseball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-basketball"  href="/sports/by_sport/basketball/"  tabindex="0">
                    <span class="nav-label">basketball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-bowling"  href="/sports/by_sport/bowling/"  tabindex="0">
                    <span class="nav-label">bowling</span>
                </a></li><li>
                <a class="nav-link   tnt-section-competitive_cheer"  href="/sports/by_sport/competitive_cheer/"  tabindex="0">
                    <span class="nav-label">competitive_cheer</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cross_country"  href="/sports/by_sport/cross_country/"  tabindex="0">
                    <span class="nav-label">cross_country</span>
                </a></li><li>
                <a class="nav-link   tnt-section-football"  href="/sports/by_sport/football/"  tabindex="0">
                    <span class="nav-label">football</span>
                </a></li><li>
                <a class="nav-link   tnt-section-golf"  href="/sports/by_sport/golf/"  tabindex="0">
                    <span class="nav-label">golf</span>
                </a></li><li>
                <a class="nav-link   tnt-section-hockey"  href="/sports/by_sport/hockey/"  tabindex="0">
                    <span class="nav-label">hockey</span>
                </a></li><li>
                <a class="nav-link   tnt-section-recreational_sports"  href="/sports/by_sport/recreational_sports/"  tabindex="0">
                    <span class="nav-label">recreational_sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-soccer"  href="/sports/by_sport/soccer/"  tabindex="0">
                    <span class="nav-label">soccer</span>
                </a></li><li>
                <a class="nav-link   tnt-section-softball"  href="/sports/by_sport/softball/"  tabindex="0">
                    <span class="nav-label">softball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-swimming"  href="/sports/by_sport/swimming/"  tabindex="0">
                    <span class="nav-label">swimming</span>
                </a></li><li>
                <a class="nav-link   tnt-section-tennis"  href="/sports/by_sport/tennis/"  tabindex="0">
                    <span class="nav-label">tennis</span>
                </a></li><li>
                <a class="nav-link   tnt-section-track"  href="/sports/by_sport/track/"  tabindex="0">
                    <span class="nav-label">track</span>
                </a></li><li>
                <a class="nav-link   tnt-section-volleyball"  href="/sports/by_sport/volleyball/"  tabindex="0">
                    <span class="nav-label">volleyball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-wrestling"  href="/sports/by_sport/wrestling/"  tabindex="0">
                    <span class="nav-label">wrestling</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-local-sports"  href="/sports/sports_local/"  tabindex="0">
                    <span class="nav-label">Local Sports</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-national-sports"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/national/"  tabindex="0">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">National Sports</span>
                </a><ul id="main-nav_menu-child-3-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-pistons"  href="/sports/national/pistons/"  tabindex="0">
                    <span class="nav-label">Pistons</span>
                </a></li><li>
                <a class="nav-link   tnt-section-tigers"  href="/sports/national/tigers/"  tabindex="0">
                    <span class="nav-label">Tigers</span>
                </a></li><li>
                <a class="nav-link   tnt-section-lions"  href="/sports/national/lions/"  tabindex="0">
                    <span class="nav-label">Lions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-red-wings"  href="/sports/national/red_wings/"  tabindex="0">
                    <span class="nav-label">Red Wings</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-college"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/national/college/"  tabindex="0">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">College</span>
                </a><ul id="main-nav_menu-child-3-child-4-child-5" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-michigan"  href="/sports/national/college/u-m/"  tabindex="0">
                    <span class="nav-label">Michigan</span>
                </a></li><li>
                <a class="nav-link   tnt-section-michigan-state"  href="/sports/national/college/msu/"  tabindex="0">
                    <span class="nav-label">Michigan State</span>
                </a></li></ul></li></ul></li><li>
                <a class="nav-link   tnt-section-international-sports"  href="/sports/international/"  tabindex="0">
                    <span class="nav-label">International Sports</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-letters-to-the-editor"  href="/opinion/letters_to_editor/"  tabindex="0">
                    <span class="nav-label">Letters To The Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-letter-to-editor"  href="/site/forms/online_services/letter"  tabindex="0">
                    <span class="nav-label">Submit Letter To Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-staff-commentaries"  href="/opinion/staff_commentaries/"  tabindex="0">
                    <span class="nav-label">Staff Commentaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-guest-commentaries"  href="/opinion/guest_commentaries/"  tabindex="0">
                    <span class="nav-label">Guest Commentaries</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-search-listings"  href="/classifieds"  tabindex="0">
                    <span class="nav-label">Search Listings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-jobs"  href="/classifieds/job/"  tabindex="0">
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cars"  href="/classifieds/vehicle/"  tabindex="0">
                    <span class="nav-label">Cars</span>
                </a></li><li>
                <a class="nav-link   tnt-section-homes"  href="/classifieds/housing/"  tabindex="0">
                    <span class="nav-label">Homes</span>
                </a></li><li>
                <a class="nav-link   tnt-section-pets"  href="/classifieds/sale/pet/"  tabindex="0">
                    <span class="nav-label">Pets</span>
                </a></li><li>
                <a class="nav-link   tnt-section-miscellaneous"  href="/classifieds/other/"  tabindex="0">
                    <span class="nav-label">Miscellaneous</span>
                </a></li><li>
                <a class="nav-link   tnt-section-apartments"  href="/classifieds/housing/rent/apartment/"  tabindex="0">
                    <span class="nav-label">Apartments</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-more"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">More</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-local-business"  href="/business"  tabindex="0">
                    <span class="nav-label">Local Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-education"  href="/education"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-health"  href="/health"  tabindex="0">
                    <span class="nav-label">Health</span>
                </a></li><li>
                <a class="nav-link   tnt-section-arts-entertainment"  href="/arts_and_entertainment/"  tabindex="0">
                    <span class="nav-label">Arts & Entertainment</span>
                </a></li><li>
                <a class="nav-link   tnt-section-religion"  href="/religion/"  tabindex="0">
                    <span class="nav-label">Religion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-kids-korner"  href="/kids_korner/"  tabindex="0">
                    <span class="nav-label">Kids Korner</span>
                </a></li><li>
                <a class="nav-link   tnt-section-farm-garden"  href="/farm_garden/"  tabindex="0">
                    <span class="nav-label">Farm Garden</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-neighbors"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/announcements/"  tabindex="0">
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Neighbors</span>
                </a><ul id="main-nav_menu-child-7-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-anniversaries"  href="/announcements/anniversaries/"  tabindex="0">
                    <span class="nav-label">Anniversaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-births"  href="/announcements/births/"  tabindex="0">
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link   tnt-section-engagements"  href="/announcements/engagements/"  tabindex="0">
                    <span class="nav-label">Engagements</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weddings"  href="/announcements/weddings/"  tabindex="0">
                    <span class="nav-label">Weddings</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link   tnt-section-legal-notices"  href="/legal_notices/"  tabindex="0">
                    <span class="nav-label">Legal Notices</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1545619" class="tncms-block hidden-lg">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546651" class="tncms-block hidden-lg">
        <div id="blox-ad-position-block-leaderboard-middle-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-middle-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1674198" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-center-middle-one1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle-one","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546650" class="tncms-block hidden-xs hidden-sm col-md-8 col-lg-9">
        <div id="blox-ad-position-block-leaderboard-middle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-middle","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546655" class="tncms-block hidden-xs hidden-sm col-md-4 col-lg-3">
        <div id="blox-ad-position-block-tile-middle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-middle","slot":"1","fold":"above","width":"200","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546656" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-pencil1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-pencil","slot":"1","fold":"above","width":"960","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="asset article-default"  data-url="https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/bdf824b4-27a0-11e8-a78f-67fc2c3cc6dd.png">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="argus-press.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.argus-press.com\/tncms\/search\/mlt\/?origin=aad77431-3d48-5e65-b7c2-ce6cb58f3772&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="asset-paging">
                <div id="paging-prev-aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="paging-link prev offset"></div>
                <div id="paging-next-aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Drug disposal event slated
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-03-30T09:40:00-04:00" class="tnt-date asset-date text-muted">
            Mar 30, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-03-30T09:40:00-04:00" class="tnt-date asset-date text-muted">4 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-03-30T09:40:00-04:00">
    <meta itemprop="datePublished" content="2021-03-30T09:40:00-04:00">
    <meta itemprop="dateModified" content="2021-03-30T09:40:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Drug%20disposal%20event%20slated&via=arguspress&url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.argus-press.com/tncms/asset/editorial/aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Argus-Press%5D%20Drug%20disposal%20event%20slated&body=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"><div id="tncms-block-1674197" class="tncms-block visible-sm visible-xs hidden-md hidden-lg">
        <div id="blox-ad-position-block-center-middle2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle","slot":"2","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1674200" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-center-middle-one1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle-one","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1788337" class="tncms-block visible-sm visible-xs hidden-md hidden-lg">
        <div id="blox-ad-position-block-center-middle3" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle","slot":"3","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>

            <div id="asset-content" data-asset-uuid="aad77431-3d48-5e65-b7c2-ce6cb58f3772">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Drug%20disposal%20event%20slated&via=arguspress&url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.argus-press.com/tncms/asset/editorial/aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Argus-Press%5D%20Drug%20disposal%20event%20slated&body=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-aad77431-3d48-5e65-b7c2-ce6cb58f3772-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="aad77431-3d48-5e65-b7c2-ce6cb58f3772" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="save-list-aad77431-3d48-5e65-b7c2-ce6cb58f3772-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="aad77431-3d48-5e65-b7c2-ce6cb58f3772" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>OWOSSO — The Shiawassee Prevention Network is hosting a prescription Drug Take Back event, according to a press release from the organization.</p></div><div class="subscriber-preview"><p>Shiawassee Prevention Network is offering a safe way to dispose of unused or expired prescription drugs from 2 to 6 p.m. April 22 at Village Care Pharmacy, 427 W. Main St.</p></div><div class="subscriber-only"><p>The event will be a drive-thru at the pharmacy, at the intersection of M-21 and M-52. Needles or liquids will not be accepted.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>People who are unable to attend the event and have prescriptions to dispose off, may do so at the following locations:</p></div><div class="subscriber-only"><p>n The Shiawassee County Sheriff’s Office lobby</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle-asset', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>n Durand City Hall lobby</p></div><div class="subscriber-only"><p>n Owosso Memorial Healthcare lobby</p></div><div class="subscriber-only"><p>n Owosso Public Safety lobby</p></div><div class="subscriber-only"><p>n Perry City Hall lobby</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom-asset', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"><div id="tncms-block-1788338" class="tncms-block hidden-md hidden-lg">
        <div id="blox-ad-position-block-center-middle4" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle","slot":"4","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Drug%20disposal%20event%20slated&via=arguspress&url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.argus-press.com/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.argus-press.com/tncms/asset/editorial/aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Argus-Press%5D%20Drug%20disposal%20event%20slated&body=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"aad77431-3d48-5e65-b7c2-ce6cb58f3772"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-aad77431-3d48-5e65-b7c2-ce6cb58f3772-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="aad77431-3d48-5e65-b7c2-ce6cb58f3772" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="aad77431-3d48-5e65-b7c2-ce6cb58f3772" class="save-list-aad77431-3d48-5e65-b7c2-ce6cb58f3772-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="aad77431-3d48-5e65-b7c2-ce6cb58f3772" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="aad77431-3d48-5e65-b7c2-ce6cb58f3772" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/news/community/owosso/article_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="aad77431-3d48-5e65-b7c2-ce6cb58f3772" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom  usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fnews%2Fcommunity%2Fowosso%2Farticle_aad77431-3d48-5e65-b7c2-ce6cb58f3772.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1587278" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-first1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-first","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584002" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-second1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-second","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584003" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-third1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-third","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586964" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-fourth1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-fourth","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546640" class="tncms-block"><section id="block-1546640" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1546640 ">
        <div class="block-title-inner">
            <h3>
                
                Sign up for our E-mail Lists
                
            </h3>
        </div>
    </div></div><div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        
            <div class="mailinglist-container">
                <div class="form-group ">
                    
                        <div class="mailinglist-item">
                            <h4 class="mailinglist-title">Breaking News</h4>
                            
                                <p>The top headlines of the day- sent right to your email!</p>
                            
                        </div>
                    
                        <div class="mailinglist-item">
                            <h4 class="mailinglist-title">News Updates</h4>
                            
                                <p><span>Would you like to receive our daily news?&nbsp;</span><strong>Signup today!</strong><span>&nbsp;</span></p>
                            
                        </div>
                    
                </div>
                <div class="form-group">
                    <a href="https://www.argus-press.com/users/admin/mailinglist/" class="btn btn-default btn-block">Manage your lists</a>
                </div>
            </div>
        
    </div></div>
        </div></div></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1587277" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-first1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-first","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584004" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-second1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-second","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584005" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-third1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-third","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586967" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-fourth1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-fourth","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1545629" class="tncms-block"></div><div id="tncms-block-1545678" class="tncms-block"><section id="block-1545678" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1545678 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1545678" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1545678" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1545678" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1545678" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1545678" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/community/corunna/article_a6db0092-8d8e-11eb-a731-5f8597dd1dba.html">Guerra sentenced to prison for posting inappropriate photos of 13-year-old girl</a></li><li><a href="/news/news_local/article_715891f7-6df5-553e-a730-8b0ec5d8081f.html">Owosso man sentenced for area break-ins</a></li><li><a href="/business/article_e7205393-2f47-528e-bb03-150aab25055a.html">OHS grad returns home, opens law firm</a></li><li><a href="/news/community/corunna/article_51e4a6df-6cc3-5d7f-993d-50d892b0c728.html">Corunna man gets jail time for witness intimidation</a></li><li><a href="/news/community/perry/article_b67588f7-5804-5976-bfa2-3b5eed917786.html">Fire’s impact struck family hard</a></li><li><a href="/news/news_local/article_25b87503-7707-5d23-8522-bc69105419b4.html">Woman sought by sheriff arrested, charged</a></li><li><a href="/business/article_7985b944-802f-5801-8782-2c6220775ff9.html">A hop, skip and jump</a></li><li><a href="/news/news_local/article_ceff80d2-de53-5644-89af-facb1b78468e.html">Man on bond for carjacking arrested again on drug charge</a></li><li><a href="/news/community/durand/article_8a27c2e2-01b0-5e62-be18-d98ae0d87da8.html">Fire burns three mobile homes near Durand</a></li><li><a href="/news/community/laingsburg/article_3761f6ba-3b2d-5191-82b9-c400d9e8e403.html">Seeking sustainability</a></li></ul></div>
        
        
            <div id="images-1545678" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/education/image_d9aae643-488d-536b-b4d6-2862ae2a3123.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="CELEBRATING WOMEN"
                            class="img-responsive lazyload full"
                            width="480"
                            height="480"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/9a/d9aae643-488d-536b-b4d6-2862ae2a3123/6058b0f198ab6.image.jpg?crop=480%2C480%2C80%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/9a/d9aae643-488d-536b-b4d6-2862ae2a3123/6058b0f198ab6.image.jpg?crop=480%2C480%2C80%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/9a/d9aae643-488d-536b-b4d6-2862ae2a3123/6058b0f198ab6.image.jpg?crop=480%2C480%2C80%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/9a/d9aae643-488d-536b-b4d6-2862ae2a3123/6058b0f198ab6.image.jpg?crop=480%2C480%2C80%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/9a/d9aae643-488d-536b-b4d6-2862ae2a3123/6058b0f198ab6.image.jpg?crop=480%2C480%2C80%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/9a/d9aae643-488d-536b-b4d6-2862ae2a3123/6058b0f198ab6.image.jpg?crop=480%2C480%2C80%2C0&resize=480%2C480&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/opinion/image_21ca9870-8eb2-11eb-aa28-e3cf22a1833b.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Filibuster Mitch"
                            class="img-responsive lazyload full"
                            width="424"
                            height="424"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/1c/21ca9870-8eb2-11eb-aa28-e3cf22a1833b/605eafdeb9750.image.jpg?crop=424%2C424%2C88%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/1c/21ca9870-8eb2-11eb-aa28-e3cf22a1833b/605eafdeb9750.image.jpg?crop=424%2C424%2C88%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/1c/21ca9870-8eb2-11eb-aa28-e3cf22a1833b/605eafdeb9750.image.jpg?crop=424%2C424%2C88%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/1c/21ca9870-8eb2-11eb-aa28-e3cf22a1833b/605eafdeb9750.image.jpg?crop=424%2C424%2C88%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/1c/21ca9870-8eb2-11eb-aa28-e3cf22a1833b/605eafdeb9750.image.jpg?crop=424%2C424%2C88%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/1c/21ca9870-8eb2-11eb-aa28-e3cf22a1833b/605eafdeb9750.image.jpg?crop=424%2C424%2C88%2C0&resize=424%2C424&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/community/durand/image_52e2f5a5-dbd8-5a41-a362-cdabc8265c48.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="GROCER HONORED"
                            class="img-responsive lazyload full"
                            width="496"
                            height="496"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/2e/52e2f5a5-dbd8-5a41-a362-cdabc8265c48/605dfa8d84503.image.jpg?crop=496%2C496%2C0%2C72&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/2e/52e2f5a5-dbd8-5a41-a362-cdabc8265c48/605dfa8d84503.image.jpg?crop=496%2C496%2C0%2C72&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/2e/52e2f5a5-dbd8-5a41-a362-cdabc8265c48/605dfa8d84503.image.jpg?crop=496%2C496%2C0%2C72&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/2e/52e2f5a5-dbd8-5a41-a362-cdabc8265c48/605dfa8d84503.image.jpg?crop=496%2C496%2C0%2C72&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/2e/52e2f5a5-dbd8-5a41-a362-cdabc8265c48/605dfa8d84503.image.jpg?crop=496%2C496%2C0%2C72&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/2e/52e2f5a5-dbd8-5a41-a362-cdabc8265c48/605dfa8d84503.image.jpg?crop=496%2C496%2C0%2C72&resize=496%2C496&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/opinion/image_1103dfb0-8eb2-11eb-ad50-ffdf2c934087.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Mallard Fillmore"
                            class="img-responsive lazyload full"
                            width="798"
                            height="798"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/10/1103dfb0-8eb2-11eb-ad50-ffdf2c934087/605eafcc13e63.image.jpg?crop=798%2C798%2C898%2C0&resize=798%2C798&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/opinion/image_c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Mallard"
                            class="img-responsive lazyload full"
                            width="798"
                            height="798"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/05/c0592cc8-8d7b-11eb-8f55-1f2e3269e7a2/605ca725af8aa.image.jpg?crop=798%2C798%2C898%2C0&resize=798%2C798&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/opinion/image_565b3552-8cb1-11eb-86e8-1739cc372044.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Mallard Fillmore"
                            class="img-responsive lazyload full"
                            width="795"
                            height="795"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/65/565b3552-8cb1-11eb-86e8-1739cc372044/605b53933688e.image.jpg?crop=795%2C795%2C906%2C0&resize=795%2C795&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/opinion/image_ac2c8e20-8d7b-11eb-a56c-0fd2a7d36bef.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Wilson"
                            class="img-responsive lazyload full"
                            width="400"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/a/c2/ac2c8e20-8d7b-11eb-a56c-0fd2a7d36bef/605ca70fd7eb8.image.jpg?crop=400%2C400%2C100%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/a/c2/ac2c8e20-8d7b-11eb-a56c-0fd2a7d36bef/605ca70fd7eb8.image.jpg?crop=400%2C400%2C100%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/a/c2/ac2c8e20-8d7b-11eb-a56c-0fd2a7d36bef/605ca70fd7eb8.image.jpg?crop=400%2C400%2C100%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/a/c2/ac2c8e20-8d7b-11eb-a56c-0fd2a7d36bef/605ca70fd7eb8.image.jpg?crop=400%2C400%2C100%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/a/c2/ac2c8e20-8d7b-11eb-a56c-0fd2a7d36bef/605ca70fd7eb8.image.jpg?crop=400%2C400%2C100%2C0&resize=400%2C400&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/opinion/image_ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="MALLARD FILLMORE"
                            class="img-responsive lazyload full"
                            width="798"
                            height="798"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/d3/ed3f947e-8e44-11eb-ab4d-f3ab75c30c8a/605df89968ede.image.jpg?crop=798%2C798%2C898%2C0&resize=798%2C798&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/opinion/image_6513da40-8cb1-11eb-b5ab-07c18863d99d.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Back to Normal"
                            class="img-responsive lazyload full"
                            width="450"
                            height="450"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/6/51/6513da40-8cb1-11eb-b5ab-07c18863d99d/605b53a388c7a.image.jpg?crop=450%2C450%2C75%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/6/51/6513da40-8cb1-11eb-b5ab-07c18863d99d/605b53a388c7a.image.jpg?crop=450%2C450%2C75%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/6/51/6513da40-8cb1-11eb-b5ab-07c18863d99d/605b53a388c7a.image.jpg?crop=450%2C450%2C75%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/6/51/6513da40-8cb1-11eb-b5ab-07c18863d99d/605b53a388c7a.image.jpg?crop=450%2C450%2C75%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/6/51/6513da40-8cb1-11eb-b5ab-07c18863d99d/605b53a388c7a.image.jpg?crop=450%2C450%2C75%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/6/51/6513da40-8cb1-11eb-b5ab-07c18863d99d/605b53a388c7a.image.jpg?crop=450%2C450%2C75%2C0&resize=450%2C450&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_d23accfe-8d8e-11eb-aa3e-affdac0ed4fa.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Kimberly Guerra"
                            class="img-responsive lazyload full"
                            width="425"
                            height="425"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/23/d23accfe-8d8e-11eb-aa3e-affdac0ed4fa/605cc72c36df2.image.jpg?crop=425%2C425%2C0%2C52&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/23/d23accfe-8d8e-11eb-aa3e-affdac0ed4fa/605cc72c36df2.image.jpg?crop=425%2C425%2C0%2C52&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/23/d23accfe-8d8e-11eb-aa3e-affdac0ed4fa/605cc72c36df2.image.jpg?crop=425%2C425%2C0%2C52&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/23/d23accfe-8d8e-11eb-aa3e-affdac0ed4fa/605cc72c36df2.image.jpg?crop=425%2C425%2C0%2C52&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/23/d23accfe-8d8e-11eb-aa3e-affdac0ed4fa/605cc72c36df2.image.jpg?crop=425%2C425%2C0%2C52&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/23/d23accfe-8d8e-11eb-aa3e-affdac0ed4fa/605cc72c36df2.image.jpg?crop=425%2C425%2C0%2C52&resize=425%2C425&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1545678" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-1545678" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/community/durand/article_958666f3-a1b0-5aeb-92c3-95582a89d4f7.html">Durand council members call for each other’s resignations</a> (2)</li><li><a href="/opinion/letters_to_editor/article_c469c118-266c-50af-948d-cd08cc3a2221.html">Trump cult needs detoxing</a> (2)</li><li><a href="/business/article_05744ef3-bf93-5e0d-a1d8-8b3f0c3a11fa.html">New Lothrop business owner hopes to block solar panels</a> (1)</li><li><a href="/opinion/guest_commentaries/article_3aff5410-afc3-5191-a223-cd9d73a492be.html">America’s grief counselor</a> (1)</li><li><a href="/news/national/article_5d024e58-aef3-57af-bf44-625e52f791dc.html">KEYTRUDA® (pembrolizumab) Plus LENVIMA® (lenvatinib) Significantly Improved Progression-Free Survival and Overall Survival Versus Chemotherapy in Patients With Advanced Endometrial Cancer Following Prior Platinum-Based Chemotherapy in Phase 3 Study</a> (1)</li><li><a href="/opinion/letters_to_editor/article_a52e5554-4c38-508d-8dfb-9fcb416ab24d.html">Lack of biblical teaching leads to violence</a> (1)</li><li><a href="/opinion/letters_to_editor/article_a54c9eeb-8fe7-580a-b6ea-0afd7d0af016.html">Anti-abortion comments display hypocrisy</a> (1)</li><li><a href="/news/community/durand/article_ad68217d-8db6-59f7-b3f1-375b88d0e5d5.html">Durand council takes ‘baby step’ to consider marijuana</a> (1)</li><li><a href="/news/national/article_cd371d08-f6dc-5b8f-a429-5f0f380c552c.html">Airline industry pushes US to standardize health papers</a> (1)</li><li><a href="/news/national/article_de3179f7-2d6b-55f3-965f-0059e835c1b4.html">Cable One Announces Private Offering of Convertible Senior Notes</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-1545661" class="tncms-block"><section id="block-1545661" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1545661 ">
        <div class="block-title-inner">
            <h3>
                
                Online Poll
                
            </h3>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/poll_bc0a883e-9153-11eb-80ad-df3790e3ef9e.html" class="tnt-asset-link">
        

        
            Are Republican efforts to change election laws justified?</a></h4>
            <div id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-your-vote"></span>
                </div>
                <div id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-results" class="tnt-poll-results hide"></div>
                <div id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-container">
                    <form id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-form" class="tnt-poll-form" role="form" method="post" action="/poll_bc0a883e-9153-11eb-80ad-df3790e3ef9e.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Yes, we need to make sure there is no fraud" value="C94E8E38-32F0-0001-3CD81A921AD01662"> Yes, we need to make sure there is no fraud
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Yes, there's not a problem if you follow the rules" value="C94E8E3B-8190-0001-8B9C1B001B8F5D80"> Yes, there's not a problem if you follow the rules
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="No, it is clearly aimed at suppressing votes" value="C94E8E3F-A7F0-0001-72991E251417187B"> No, it is clearly aimed at suppressing votes
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="No, there is no evidence of widespread fraud" value="C94E8E45-F980-0001-75DA158014B01FF9"> No, there is no evidence of widespread fraud
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="I don't know" value="C94E8E4F-8470-0001-29E916B915001578"> I don't know
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-back-vote" class="padding-top hide">
                <button id="poll-bc0a883e-9153-11eb-80ad-df3790e3ef9e-1545661-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div><div id="tncms-block-1546647" class="tncms-block"><section id="block-1546647" class="block emphasis-h3    tnt-no-margin-bottom tnt-has-block-bg" ><div class="clearfix">
    
    <div class="block-title title-1546647 ">
        <div class="block-title-inner">
            <h3>
                
                Find more information
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-1546647-1ac77ab0-0d18-11e0-b4b6-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-1ac77ab0-0d18-11e0-b4b6-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.chesaningschools.net" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Chesaning Union Schools"
                            class="img-responsive lazyload full"
                            width="202"
                            height="184"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/ac/1ac77ab0-0d18-11e0-b4b6-001cc4c002e0/5fac03ff535eb.preview.jpg?crop=202%2C184%2C85%2C7&resize=150%2C137&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/ac/1ac77ab0-0d18-11e0-b4b6-001cc4c002e0/5fac03ff535eb.preview.jpg?crop=202%2C184%2C85%2C7&resize=200%2C182&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/1/ac/1ac77ab0-0d18-11e0-b4b6-001cc4c002e0/5fac03ff535eb.preview.jpg?crop=202%2C184%2C85%2C7&resize=202%2C184&order=crop%2Cresize 225w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.chesaningschools.net" class="tnt-asset-link">
        

        
            Chesaning Union Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-b9c05fe8-0d17-11e0-a264-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-b9c05fe8-0d17-11e0-a264-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.laingsburg.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Laingsburg Community Schools"
                    class="img-responsive lazyload  letterbox"
                    width="100"
                    height="103"
                    data-src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/b/9c/b9c05fe8-0d17-11e0-a264-001cc4c002e0/5abe6b5d2719f.preview.jpg" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.laingsburg.k12.mi.us/" class="tnt-asset-link">
        

        
            Laingsburg Community Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-c9b5bd8a-0d17-11e0-89c1-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-c9b5bd8a-0d17-11e0-89c1-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.morrice.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Morrice Area Schools"
                            class="img-responsive lazyload full"
                            width="1638"
                            height="1266"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=150%2C116 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=200%2C155 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=225%2C174 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=300%2C232 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=400%2C309 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=540%2C417 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=640%2C495 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=750%2C580 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=990%2C765 990w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=1035%2C800 1035w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=1200%2C927 1200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=1333%2C1030 1333w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg?resize=1476%2C1141 1476w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/9b/c9b5bd8a-0d17-11e0-89c1-001cc4c002e0/5fac04453a1fa.preview.jpg 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.morrice.k12.mi.us/" class="tnt-asset-link">
        

        
            Morrice Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-df18cca8-0d17-11e0-a274-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-df18cca8-0d17-11e0-a274-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://byron.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Byron Area Schools"
                            class="img-responsive lazyload full"
                            width="750"
                            height="516"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=150%2C103 150w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=200%2C138 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=225%2C155 225w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=300%2C206 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=400%2C275 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=540%2C372 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=640%2C440 640w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5fac04e6495ce.preview.jpg?resize=750%2C516 750w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://byron.k12.mi.us/" class="tnt-asset-link">
        

        
            Byron Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-edd711f0-0d17-11e0-85e4-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-edd711f0-0d17-11e0-85e4-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.newlothrop.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="New Lothrop Area Schools"
                    class="img-responsive lazyload  letterbox"
                    width="215"
                    height="220"
                    data-src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/dd/edd711f0-0d17-11e0-85e4-001cc4c002e0/5fac050936d43.preview.jpg?resize=200%2C205" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.newlothrop.k12.mi.us/" class="tnt-asset-link">
        

        
            New Lothrop Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-033f698a-0d17-11e0-a164-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-033f698a-0d17-11e0-a164-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.corunna.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Corunna Public Schools"
                            class="img-responsive lazyload full"
                            width="150"
                            height="150"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/0/33/033f698a-0d17-11e0-a164-001cc4c002e0/5fac051502a14.preview.jpg?resize=150%2C150" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.corunna.k12.mi.us/" class="tnt-asset-link">
        

        
            Corunna Public Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-55b0914e-0d17-11e0-a176-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-55b0914e-0d17-11e0-a176-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.durand.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Durand Area Schools"
                            class="img-responsive lazyload full"
                            width="100"
                            height="95"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/5b/55b0914e-0d17-11e0-a176-001cc4c002e0/5abe81b6436da.preview.gif?resize=100%2C95" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.durand.k12.mi.us/" class="tnt-asset-link">
        

        
            Durand Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-9b0881f2-0d17-11e0-a2d9-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-9b0881f2-0d17-11e0-a2d9-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.perry.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Perry Public Schools"
                            class="img-responsive lazyload full"
                            width="100"
                            height="71"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/9/b0/9b0881f2-0d17-11e0-a2d9-001cc4c002e0/5abe81dbaf2e3.preview.jpg?resize=100%2C71" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.perry.k12.mi.us/" class="tnt-asset-link">
        

        
            Perry Public Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-e8b908aa-0d16-11e0-b308-001cc4c002e0" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-e8b908aa-0d16-11e0-b308-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="http://www.owosso.k12.mi.us/" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Owosso Public Schools"
                            class="img-responsive lazyload full"
                            width="100"
                            height="92"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/8b/e8b908aa-0d16-11e0-b308-001cc4c002e0/5abe81f768acb.preview.png?resize=100%2C92" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.owosso.k12.mi.us/" class="tnt-asset-link">
        

        
            Owosso Public Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-5958a9b2-2431-11eb-9572-73cae2a5b90b" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style- ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-5958a9b2-2431-11eb-9572-73cae2a5b90b media-preview link-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-">
            <div class="image" 
                >
                
                    <a href="https://www.ovidelsie.org" class="tnt-asset-link" >                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Ovid-Elsie Area Schools"
                    class="img-responsive lazyload  letterbox"
                    width="1067"
                    height="1079"
                    data-src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/eb/ceb368a6-3c10-11e9-ab0f-6b039072eb4f/5c7910199faf6.image.jpg?resize=200%2C202" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="https://www.ovidelsie.org" class="tnt-asset-link">
        

        
            Ovid-Elsie Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div><span class="clearfix"></span></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1587276" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-first1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-first","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586968" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-second1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-second","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586969" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-third1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-third","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586970" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-fourth1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-fourth","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1545620" class="tncms-block hidden-xs hidden-sm col-md-8 col-lg-9">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1545621" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586965" class="tncms-block hidden-xs hidden-sm col-md-4 col-lg-3">
        <div id="blox-ad-position-block-tile-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-bottom","slot":"1","fold":"above","width":"200","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1545718" class="tncms-block"><section id="block-1545718" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1545718 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/business"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-photo-gallery"  href="/gallery"  tabindex="0">
                    <span class="nav-label">Photo Gallery</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1545669" class="tncms-block"><section id="block-1545669" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1545669 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-online-forms"  href="/site/forms"  tabindex="0">
                    <span class="nav-label">Online Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/site/forms/online_services/place_an_ad/"  tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-email-alerts"  href="/users/admin/mailinglist"  tabindex="0">
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-search"  href="/search"  tabindex="0">
                    <span class="nav-label">Search</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1545720" class="tncms-block"><section id="block-1545720" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1545720 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>www.argus-press.com</strong><br>
    201 E. Exchange Street<br>
    Owosso, MI 48867
    <br>
    
        <strong>Phone:</strong> (989) 725-5136<br>
        <strong>Email:</strong> <a href="mailto:news@argus-press.com">news@argus-press.com</a><br>
    
</address></section></div><div id="tncms-block-1545728" class="tncms-block padding-bottom"><div class="follow-links-1545728 default">
    
    <section id="block-1545728" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/arguspress/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.argus-press.com",
  "sameAs" : ["http://facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846","http://twitter.com/arguspress/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1545673" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1545673"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">The Argus-Press</a>, 201 E. Exchange Street Owosso, MI</small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/news\/community\/owosso","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("aad77431-3d48-5e65-b7c2-ce6cb58f3772")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script></body>
</html>