  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.argus-press.com/content/tncms/live/" />
<meta name="keywords" content="obituaries" />
<meta name="news_keywords" content="obituaries" />
<meta name="description" content="Age 82, of Durand, passed away Saturday, July 27, 2019, at her home." />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.argus-press.com/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=425%2C616" />
<meta property="og:image:width" content="425" />
<meta property="og:image:height" content="616" />
<meta property="og:title" content="Deanna G. Springs" />
<meta property="og:description" content="Age 82, of Durand, passed away Saturday, July 27, 2019, at her home." />
<meta property="og:site_name" content="The Argus-Press" />
<meta property="og:section" content="Obituaries" />
<meta property="fb:app_id" content="140096299389133" />
<meta property="article:publisher" content="https://www.facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@arguspress" />
<meta name="twitter:image:alt" content="Deanna G. Springs" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.8aebbe9627939cd5a7c8e4f6930a23bd.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.f85bdd8ecb1a515ca678ac2197765d61.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.4cce04b95f9b49884d7452d4a02f3f09.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,600,700"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.142.0"},"page":{"grid":"boxy","style":"default","path":"\/obituaries","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":430},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "851,890,2611,2612", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d1a4f9eb1701d7bb8dd985a2ca0981e5.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.9ef2deb39dff2c51bd3efbbfc097b065.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.2298fa2c06ac9b301ef502070168c6dc.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.9329546da5f585bc9c9c9b7f9d6df105.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb8ce7db3d97ee68fa83a4ab2b12db43.js"></script>
<script>/*<![CDATA[*/ (function(d,w,s){
        if(w.fetch&&w.Promise&&w.IntersectionObserver&&[].includes&&Object.assign&&w.Map&&w.NodeList)return;
        var sc=d.getElementsByTagName(s)[0],js=d.createElement(s);
        js.src='https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator';
        sc.parentNode.insertBefore(js, sc);
    }(document,window,'script')) /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.6cc3c6b5c89c0c6e8d3e48f50b65f875.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/impressions.js?_dc=1564493702"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/traffic.js?_dc=1564461303"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/settings.js?_dc=1564426364"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1554145834"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-middle-asset/1.js?_dc=1530884320"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-bottom-asset/1.js?_dc=1530884232"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.89c459acbb5b3f64e6ad65972d5f7da0.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"#FFFFFF","list_ids":"cb376124-e497-11e5-aa65-0323eecfec65, cadc77e8-d4f5-11e5-8631-5fa74c5b78b4","require_user_account":"1","signup_lists_only":"","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","text_color":"inherit","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_audience":"","hide_audience":"","block_id":"1546640"}); /*]]>*/</script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661","asset_id":"d9a5216a-b216-11e9-a9fc-1fb6e77631a7","title":"Did Robert Mueller\\'s televised testimony sway your opinion on Trump at all?","url":"\/poll_d9a5216a-b216-11e9-a9fc-1fb6e77631a7.html","results":"https:\/\/www.argus-press.com\/poll_d9a5216a-b216-11e9-a9fc-1fb6e77631a7.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/ads/fixed-big-ad-bottom/1.js?_dc=1530884330"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>

            
            <title>Deanna G. Springs | Obituaries | argus-press.com</title>
            
    <style>body { background-color: #eeeeee; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #252525; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #eeeeee; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #eee; } .fixed-nav #main-navigation { background-color: #eee !important; } #site-top-nav-container, #site-top-nav { background-color: #000; } #site-footer-container, #site-footer { background-color: #252525; color: #fff; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000; } .navbar-toggle .icon-bar { background-color: #000 !important; } .navbar-toggle .sr-only-show { color: #000 !important; } #site-top-nav .list-inline>li>a { color: #fff; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #eee; }/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000; } }#site-copyright a, #site-footer a { color: #fff; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /************** Variables --------------- These variables control the colors of the buttons. If changing the colors of buttons, change the color here rather than in the actual css. ***************/ body {font-family:'Open Sans', sans-serif;} .btn {transition:all .25s ease-in-out;} .btn-default {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37); color:#fff!important;} .btn-default:hover, .btn-default:focus {background-color:rgb(136, 21, 24); border-color:rgb(136, 21, 24);} .btn-primary {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .btn-primary:hover, .btn-primary:focus {background-color:rgb(136, 21, 24); border-color:rgb(136, 21, 24);} .btn-warning {background-color:#FFCE34; border-color:#FFCE34;} .btn-warning:hover, .btn-warning:focus {background-color:#D8B02B; border-color:#D8B02B;} .btn-success {background-color:#275B33; border-color:#275B33;} .btn-success:hover, .btn-success:focus {background-color:#1F4929; border-color:#1F4929;} .btn-danger {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .btn-danger:hover, .btn-danger:focus {background-color:rgb(136, 21, 24); border-color:rgb(136, 21, 24);} .label-primary {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .label-warning {background-color:#FFCE34; border-color:#FFCE34;} .label-success {background-color:#275B33; border-color:#275B33;} .label-danger {background-color:rgb(169, 33, 37); border-color:rgb(169, 33, 37);} .nav-pills>li.active>a, .nav-pills>li.active>a:focus, .nav-pills>li.active>a:hover {background-color:rgb(136, 21, 24);} .progress-bar {background-color:#275B33;} /* HEADER */ #topbar-col-two-nav_menu {text-align:right;} #site-header {padding-bottom:0px;} #site-header > .row:nth-child(2) {padding:10px 0; background:rgb(169, 33, 37); background:linear-gradient(rgb(136, 21, 24), rgb(169, 33, 37));} #masthead-col-one, #masthead-col-two {width:50%;} #navbar-collapse > .pull-right {max-width:30%;} #navbar-collapse > .pull-right .search-form-container {margin:7px 10px!important;} #main-nav_menu > li > a {font-family:'Open Sans', sans-serif; text-transform:uppercase; font-weight:700;} #site-navbar-container .navbar-static .navbar-nav>li>a {border-right:1px solid rgba(255,255,255,.05);} #site-search-1545725-dropdown .dropdown-toggle {margin-top:5px; color:#fff;} #site-search-1545725-dropdown .dropdown-menu {left:0;} #user-controls-1545729 {padding-top:10px;} #blox-ad-position-fixed-impact-top1 {min-height:90px;} #blox-ad-position-fixed-impact-top1 .tnt-expandable-small {min-height:90px;} #blox-ad-position-fixed-impact-top1 .tnt-expandable-small img {position:fixed; top:0; z-index:9999;} #site-search-1545725-dropdown .dropdown-menu {padding: 15px; width: 250px; font-weight: normal;} /* BODY */ .block-title-inner * {font-family:'Open Sans', sans-serif; text-transform:uppercase; font-weight:700;} #tncms-block-1545679 .block, #tncms-block-1545679 .heading {margin-bottom:0!important;} /* Dynamic Block title */ #tncms-block-1545679 .heading a {text-decoration:none!important} /* Dynamic Block title */ .card-headline a {font-weight:600;} .search-form-container, .panel-default>.panel-heading {background-color:rgba(37,37,37,0.06);} .subscription-service.panel-default>.service-heading {background:#252525;} .most-popular .tab-content {background:#fff;} .subscription .modal-body a {color:white!important;} .subscription .modal-body .no-services a {color:white; padding:5px 10px; display:inline-block; border-radius:3px; background-color:rgb(169, 33, 37); transition:all .3s;} .subscription .modal-body .no-services a:hover {background-color:rgb(136, 21, 24); text-decoration:none;} .form-category-forms h4 {font-size:2em;} .form-category-forms a {font-size:1.2em; line-height:2em;} .featured-photos .image {max-height:500px;} @media (max-width:991px) { button.hamburger-desktop.navbar-toggle.pull-left {display:none;} #main-navigation {height:65px; background:rgb(169, 33, 37); background:linear-gradient(rgb(136, 21, 24), rgb(169, 33, 37));} .navbar-brand img {max-height:45px;} .navbar-toggle .icon-bar {background:#fff!important;} } @media (max-width:350px) { #main-navigation {height:50px;} .navbar-brand img {max-height:30px;} } /* iPhone 5 ----------- */ @media only screen and (min-device-width: 320px) and (max-device-height:568px) and (orientation: landscape) { .tnt-ads { padding-bottom: 12px; } } @media only screen and (min-device-width: 320px) and (max-device-height: 568px) and (orientation: portrait) { .tnt-ads { padding-bottom: 12px; } } /* jsandy #678250 */ #blox-ad-position-fixed-impact-top1 {min-height: 1px;} .tncms-region-ads div:first-child, .tnt-ads, .tnt-ads-container div:first-child {margin-bottom: 20px;} @media screen and (max-width: 970px) { #blox-ad-position-fixed-impact-top1 {display: none;} } @media (max-width: 991px) { #main-navigation { height: 85px; } } </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.argus-press.com/content/tncms/site/icon.ico" />
    
        <link rel="dns-prefetch preconnect" href="//tagan.adlightning.com">
    
        <link rel="dns-prefetch preconnect" href="//cdn.taboola.com">
    
        <link rel="dns-prefetch preconnect" href="//www.googletagmanager.com">
    
        <link rel="dns-prefetch preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Deanna G. Springs | Obituaries | argus-press.com" href="http://www.argus-press.com/search/?f=rss&amp;t=article&amp;c=obituaries&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.argus-press.com/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html" />
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.4a9fdca450d57375be3be7a06b5bc5f0.js"></script>
            
        </head>
        <body class="fixed-scroll-nav  blox-asset app-editorial uuid-7f67ce45-bc64-5ced-94d4-44d93d2b93e4  section-obituaries type-article infinity-disabled">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.argus-press.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.142.0&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fobituaries&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=true&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.ad.vendor=blox&tncms.system.render_time=430&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.argus-press.com",
  secureDomain: "www.argus-press.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>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</script>

    
<div id="template-metering" data-message-mode="subscription-wall">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for Reading!

                </h4>
                <p>Please <span class="not-logged-in">log in, or sign up for a new account and</span> purchase a subscription to continue reading.</p>

                <div class="col-xs-12">
                    <div class="row not-logged-in">

                        <div class="col-xs-6">
                            
    <a class="btn btn-default btn-block" href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">Sign Up</a>
                        </div>
                        <div class="col-xs-6">
                            
    <a class="btn btn-primary btn-block" href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">Log In</a>
                        </div>
                    </div>
                    <div class="row logged-in">
                        <div class="pull-right">
                            <a class="btn btn-default meter-modal-open">Purchase a Subscription
</a>
                        </div>
                    </div>
                    </div>
            </div>
        </div>
        </div>
    
    
</template>
    
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="blox modal subscription">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Thank you for Reading!
</h4>
            </div>
            
            <div class="modal-body">
                <div class="row">
                    <div class="col-xs-12">
                    <div class="not-logged-in">
                            <p>Please log in, or sign up for a new account and purchase a subscription to continue reading.
</p>
                        </div>
            
                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Please purchase a subscription to continue reading.
</p>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.
</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    
    <a class="btn btn-default btn-block" href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">Sign Up</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-primary btn-block" href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">Log In</a>
                                </div>
                            </div>
                        </div>
                        
                    <div class="col-xs-12">
                            </div>
                        
                        <div class="col-xs-12 logged-in">
                            <div class="subscription-services">
    <script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[851] = {
    'name':'Online Paywall Access',
    'id':'851',
    'prices':['200','750','2250','4500','9000'],
    'brand':'subscription',
    'category':'subscription',
    'list':'Article'
};
</script>
<div data-service-id="851" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Online Paywall Access</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>Please purchase an Online Pass to gain access to our Online Content.</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            <span class="text-muted">Starting at</span><div class="service-price-text">
                                    $2.00
                                    
                                        
for 1 day

                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="851" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.argus-press.com/users/admin/service/purchase/?serviceid=851&referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
            <div class="panel-footer">
                <div class="view-rates-container">
                    <a class="view-rates-link" data-toggle="collapse" href="#collapse-rates-851">
                        <span class="view-rates-text">View all rates</span> <i class="fas tnt-caret-down"></i>
                    </a>
                </div>
                <div id="collapse-rates-851" class="collapse collapse-rates">
                    <table class="table table-striped table-condensed">
                        <thead>
                            <tr>
                                <th>Rate</th>
                                <th>Price</th>
                                <th>Duration</th>
                            </tr>
                        </thead>
                        <tbody>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">One Day Access</td>
                                    <td class="service-rate-cell-price">
                                        $2.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 1 day
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">One Month Access - 30 days</td>
                                    <td class="service-rate-cell-price">
                                        $7.50
                                    </td>
                                    <td class="service-rate-cell-duration">
for 30 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Three Month Access - 90 days</td>
                                    <td class="service-rate-cell-price">
                                        $22.50
                                    </td>
                                    <td class="service-rate-cell-duration">
for 90 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">Six Month Access - 180 days</td>
                                    <td class="service-rate-cell-price">
                                        $45.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 180 days
</td>
                                </tr>
                            
                                <tr class="service-rate">
                                    <td class="service-rate-cell-name">One Year Access - 365 days</td>
                                    <td class="service-rate-cell-price">
                                        $90.00
                                    </td>
                                    <td class="service-rate-cell-duration">
for 365 days
</td>
                                </tr>
                            
                        </tbody>
                    </table>
                </div>
            </div>
        
    </div><script>
window.__tnt || (window.__tnt = {});
__tnt.services || (__tnt.services = {});
__tnt.services[890] = {
    'name':'Print Subscribers Registration for Access',
    'id':'890',
    'prices':[''],
    'brand':'csv',
    'category':'subscription',
    'list':'Article'
};
</script>
<div data-service-id="890" class="subscription-service panel panel-default subscription-service-digital ">
        <div class="panel-heading service-heading">
            <h3 class="panel-title">Print Subscribers Registration for Access</h3>
        </div>
        <div class="panel-body">
            
            
            <div class="service-desc">
                <p>Online Access for Print Subscribers. &nbsp;Do you have a print subscription with the Argus-Press? If yes, then click here to enjoy complimentary access to our Online Content!</p>
            </div>
            <div class="row row-eq-height">
                
                <div class="col-sm-6 align-bottom">
                    <div class="service-rates">
                        
                            
                                <div class="service-price-text">
                                    Free
                                    
                                        access for current print subscribers
                                    
                                </div>
                            
                        
                    </div>
                </div>
                <div class="col-sm-6 align-bottom">
                        <div class="service-sublink">
                            <a data-subscription-service="890" data-subscription-service-zipcodes="" class="btn btn-primary pull-right" href="https://www.argus-press.com/users/admin/service/purchase/?serviceid=890&referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">Get Started</a>
                        </div>
                    
                </div>
                
            </div>
        </div>
        
    </div>

    
</div>

<script>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</script></div>
                        
                    </div>
                </div>            
            </div>
            <div class="modal-footer">
                <div class="logged-in">
                
                </div>
                
            </div>
        </div>
    </div>
</div>

<form id="zipcode-restriction" class="form-inline" method="get" action="/users/admin/service/purchase/">
    <input type="hidden" name="serviceid" value=""/>
    <input type="hidden" name="referer_url" value="/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"/>
    <input type="hidden" name="promoCode" value=""/>
    <input type="hidden" name="rate_id" value=""/>

    <div class="modal fade">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                    <h4 class="modal-title">Let's Confirm You're In Our Delivery Area</h4>
                </div>
                <div class="modal-body">
                    <div class="zipcode-restriction-warning alert alert-warning hidden">
                        <p><strong>Sorry</strong>, this zipcode is not in our deliverable area for this subscription service.</p>
                        <p>Re-enter zip code or sign up for digital access.</p>
                        <p class="text-right"><a class="alert-link" href="/users//admin/service/purchase/?services=digital">Get digital access</a></p>
                    </div>

                    <p>Please confirm you are in our delivery area</p>
                    <div class="form-group">
                        <label for="zipcode">Zip Code</label>
                        <input type="text" class="form-control" name="zipcode" placeholder="Enter location" value="">
                    </div>

                </div>
                <div class="modal-footer">
                    <button type="button" class="btn btn-default pull-left" data-dismiss="modal">Cancel</button>

                    <button type="submit" class="btn btn-primary pull-right">Confirm</button>
                </div>
            </div>
        </div>
    </div>
</form>

<script>
    $(function(){
       var zipcodes = [];

       $.each($('.subscription-services .subscription-service.subscription-service-delivered'),function(){
           $(this).find('.service-sublink a.btn.btn-primary').on('click',function(){
               $('#zipcode-restriction').find('input[name=serviceid]').val($(this).attr('data-subscription-service'));
               zipcodes = $(this).attr('data-subscription-service-zipcodes').split(',');

               $('#template-metering').find('.metering-modal').modal('toggle');
               $('#zipcode-restriction').find('.modal').modal({});

               return false;
           });
       });


       $('#zipcode-restriction').find('.zipcode-restriction-modal').on('click',function(){
           $('#template-metering').find('.metering-modal').modal('toggle');
           $('#zipcode-restriction').find('.modal').modal({
               static:'static',
               keyboard:false
            });

            return false;
       });


       $('#zipcode-restriction').on('submit',function(){
           if($('#zipcode-restriction').find('[name=zipcode]').val()!=""){

               if($.inArray($('#zipcode-restriction').find('[name=zipcode]').val(), zipcodes) > -1){
                   console.log("form is valid, should submit");
               }else{
                   console.log("form is catching on zipcode check");

                   $('#zipcode-restriction').find('.zipcode-restriction-warning').removeClass('hidden').show();

                   return false;
               }
           } else {
               console.log("form is catching on zipcode blank check");
               return false;
           }
       });
    });
</script>

        
<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
        $('#eedition-subscription').find('.meter-modal-open').on('click',function(){
            $("#template-metering").find('.metering-modal').first().modal();
        });
    });
    
</script>
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(851);
                
                bloxServiceIDs.push(890);
                
                bloxServiceIDs.push(2611);
                
                bloxServiceIDs.push(2612);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-edit-container-7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fas tnt-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this article.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://www.argus-press.com/users/admin/contribute/article/?assetid=7f67ce45-bc64-5ced-94d4-44d93d2b93e4&assettype=article"><i class="fas tnt-pen-square"></i> Edit Article</a>
                    
                        <a class="btn btn-danger" href="https://www.argus-press.com/users/admin/contribute/article/?from_section=/obituaries"><i class="fas tnt-plus-square"></i> Add New Article</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div><script>
        var oAuthors = [];jQuery(document).ready(function($){
            if( __tnt.user.loggedIn && jQuery.inArray(__tnt.user.screenName, oAuthors) !==-1 ){
                __tnt.isAuthor = true;
                $('.asset-owner-content').show();
            }
        });
    </script>

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left ">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/nie.html"  class="nav-link tnt-section-newspapers-in-education">Newspapers in Education</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/subscribe/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/news/"  class="nav-link tnt-section-local-news">Local News</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/sports/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/news/community/bancroft/"  class="nav-link tnt-section-bancroft">Bancroft</a>
                                </li><li>
                                    <a href="/news/community/byron/"  class="nav-link tnt-section-byron">Byron</a>
                                </li><li>
                                    <a href="/news/community/chesaning/"  class="nav-link tnt-section-chesaning">Chesaning</a>
                                </li><li>
                                    <a href="/news/community/corunna/"  class="nav-link tnt-section-corunna">Corunna</a>
                                </li><li>
                                    <a href="/news/community/durand/"  class="nav-link tnt-section-durand">Durand</a>
                                </li><li>
                                    <a href="/news/community/elsie/"  class="nav-link tnt-section-elsie">Elsie</a>
                                </li><li>
                                    <a href="/news/community/laingsburg/"  class="nav-link tnt-section-laingsburg">Laingsburg</a>
                                </li><li>
                                    <a href="/news/community/lennon/"  class="nav-link tnt-section-lennon">Lennon</a>
                                </li><li>
                                    <a href="/news/community/morrice/"  class="nav-link tnt-section-morrice">Morrice</a>
                                </li><li>
                                    <a href="/news/community/new_lothrop/"  class="nav-link tnt-section-new-lothrop">New Lothrop</a>
                                </li><li>
                                    <a href="/news/community/ovid/"  class="nav-link tnt-section-ovid">Ovid</a>
                                </li><li>
                                    <a href="/news/community/owosso/"  class="nav-link tnt-section-owosso">Owosso</a>
                                </li><li>
                                    <a href="/news/community/perry/"  class="nav-link tnt-section-perry">Perry</a>
                                </li><li>
                                    <a href="/news/community/shiawassee_area/"  class="nav-link tnt-section-shiawassee-area">Shiawassee Area</a>
                                </li><li>
                                    <a href="/news/community/vernon/"  class="nav-link tnt-section-vernon">Vernon</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters_to_editor">Letters_to_editor</a>
                                </li><li>
                                    <a href="/site/forms/online_services/letter/"  class="nav-link tnt-section-submit-letter-to-the-editor">Submit Letter to the Editor</a>
                                </li><li>
                                    <a href="/opinion/staff_commentaries/"  class="nav-link tnt-section-staff_commentaries">Staff_commentaries</a>
                                </li><li>
                                    <a href="/opinion/guest_commentaries/"  class="nav-link tnt-section-guest_commentaries">Guest_commentaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/business/"  class="nav-link tnt-section-local-business">Local Business</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/education/"  class="nav-link tnt-section-education">Education</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/health"  class="nav-link tnt-section-health">Health</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/arts_and_entertainment/"  class="nav-link tnt-section-arts-entertainment">Arts & Entertainment</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/religion/"  class="nav-link tnt-section-religion">Religion</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/kids_korner/"  class="nav-link tnt-section-kids-korner">Kids Korner</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/farm_garden/"  class="nav-link tnt-section-farmgarden">Farm/Garden</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-14" data-target="#mobile-nav-left_menu-child-14">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/announcements/"  class="nav-link tnt-section-neighbors">Neighbors</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-14" class="collapse nav navbar-nav"><li>
                                    <a href="/announcements/anniversaries/"  class="nav-link tnt-section-anniversaries">Anniversaries</a>
                                </li><li>
                                    <a href="/announcements/births/"  class="nav-link tnt-section-births">Births</a>
                                </li><li>
                                    <a href="/announcements/engagements/"  class="nav-link tnt-section-engagements">Engagements</a>
                                </li><li>
                                    <a href="/announcements/weddings/"  class="nav-link tnt-section-weddings">Weddings</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-15" data-target="#mobile-nav-left_menu-child-15">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/world_news/state_news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-15" class="collapse nav navbar-nav"><li>
                                    <a href="/world_news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a href="/world_news/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/world_news/international/"  class="nav-link tnt-section-international">International</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-16" data-target="#mobile-nav-left_menu-child-16">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/sports_local/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-16" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/sports/international/"  class="nav-link tnt-section-international">International</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-19" data-target="#mobile-nav-left_menu-child-19">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-19" class="collapse nav navbar-nav"><li>
                                    <a href="/classifieds/"  class="nav-link tnt-section-search-listings">Search Listings</a>
                                </li><li>
                                    <a href="/classifieds/job/"  class="nav-link tnt-section-job">Job</a>
                                </li><li>
                                    <a href="/classifieds/vehicle/"  class="nav-link tnt-section-vehicle">Vehicle</a>
                                </li><li>
                                    <a href="/classifieds/housing/"  class="nav-link tnt-section-housing">Housing</a>
                                </li><li>
                                    <a href="/classifieds/sale/pet"  class="nav-link tnt-section-pets">Pets</a>
                                </li><li>
                                    <a href="/classifieds/other"  class="nav-link tnt-section-miscellaneous">Miscellaneous</a>
                                </li><li>
                                    <a href="classifieds/housing/rent/apartment"  class="nav-link tnt-section-apartments">Apartments</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/legal_notices/"  class="nav-link tnt-section-legal-notices">Legal Notices</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-1545730" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1545730" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.argus-press.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-1545730').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.argus-press.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.argus-press.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.argus-press.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1545730').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.argus-press.com/users/logout/" id="user-logout-form-1545730"><input type="hidden" name="referer_url" value="https://www.argus-press.com/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/nie.html"  class="nav-link tnt-section-newspapers-in-education">Newspapers in Education</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a href="/site/forms/"  class="nav-link tnt-section-online-forms">Online Forms</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/news_local/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/news_local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/community/"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a href="/world_news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a href="/world_news/national/"  class="nav-link tnt-section-national-news">National News</a>
                                </li><li>
                                    <a href="/world_news/international/"  class="nav-link tnt-section-international-news">International News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/sports_local/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/by_school/"  class="nav-link tnt-section-by-school">By School</a>
                                </li><li>
                                    <a href="/sports/by_sport/"  class="nav-link tnt-section-by-sport">By Sport</a>
                                </li><li>
                                    <a href="/sports/sports_local/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                                </li><li>
                                    <a href="/sports/national/"  class="nav-link tnt-section-national-sports">National Sports</a>
                                </li><li>
                                    <a href="/sports/international/"  class="nav-link tnt-section-international-sports">International Sports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters To The Editor</a>
                                </li><li>
                                    <a href="/site/forms/online_services/letter/"  class="nav-link tnt-section-submit-letter-to-editor">Submit Letter To Editor</a>
                                </li><li>
                                    <a href="/opinion/staff_commentaries/"  class="nav-link tnt-section-staff-commentaries">Staff Commentaries</a>
                                </li><li>
                                    <a href="/opinion/guest_commentaries/"  class="nav-link tnt-section-guest-commentaries">Guest Commentaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/classifieds/"  class="nav-link tnt-section-search-listings">Search Listings</a>
                                </li><li>
                                    <a href="/classifieds/job/"  class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a href="/classifieds/vehicle/"  class="nav-link tnt-section-cars">Cars</a>
                                </li><li>
                                    <a href="/classifieds/housing/"  class="nav-link tnt-section-homes">Homes</a>
                                </li><li>
                                    <a href="/classifieds/sale/pet/"  class="nav-link tnt-section-pets">Pets</a>
                                </li><li>
                                    <a href="/classifieds/other/"  class="nav-link tnt-section-miscellaneous">Miscellaneous</a>
                                </li><li>
                                    <a href="/classifieds/housing/rent/apartment/"  class="nav-link tnt-section-apartments">Apartments</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-more">More</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/business/"  class="nav-link tnt-section-local-business">Local Business</a>
                                </li><li>
                                    <a href="/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a href="/health"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a href="/arts_and_entertainment/"  class="nav-link tnt-section-arts-entertainment">Arts & Entertainment</a>
                                </li><li>
                                    <a href="/religion/"  class="nav-link tnt-section-religion">Religion</a>
                                </li><li>
                                    <a href="/kids_korner/"  class="nav-link tnt-section-kids-korner">Kids Korner</a>
                                </li><li>
                                    <a href="/farm_garden/"  class="nav-link tnt-section-farm-garden">Farm Garden</a>
                                </li><li>
                                    <a href="/announcements/"  class="nav-link tnt-section-neighbors">Neighbors</a>
                                </li><li>
                                    <a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                                </li><li>
                                    <a href="/legal_notices/"  class="nav-link tnt-section-legal-notices">Legal Notices</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-1545726" class="tncms-block hidden-md hidden-lg"><section id="block-1545726" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1545726" class="search-form-container card clearfix text-center ">
    <form id="site-search-1545726" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-1545726-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1545726-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1545726-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1545726').submit();
        return false;
    });

    $('#site-search-1545726').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1545726 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1545726 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1545726-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script></div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1545725" class="tncms-block padding-right padding-left pull-left"><ul id="site-search-1545725-dropdown" class="nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1545725" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-1545725-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1545725-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1545725-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1545725').submit();
        return false;
    });

    $('#site-search-1545725').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1545725 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1545725 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1545725-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script></div><div id="tncms-block-1545727" class="tncms-block padding-left padding-right pull-left"><div class="follow-links-1545727 default">
    
    <section id="block-1545727" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/arguspress/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.argus-press.com",
  "sameAs" : ["https://www.facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846","http://twitter.com/arguspress/"]
}
</script>
<div class="clearfix"></div></div></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-two-nav" class="tncms-region-nav"><ul id="topbar-col-two-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services/subscribe/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-forms"  href="/site/forms/" >
                    <span class="nav-label">Online Forms</span>
                </a></li></ul></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-1545618" class="tncms-block hidden-xs hidden-sm col-md-8 col-lg-9">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546652" class="tncms-block hidden-xs hidden-sm col-md-4 col-lg-3">
        <div id="blox-ad-position-block-tile-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-top","slot":"1","fold":"above","width":"200","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1545677" class="tncms-block"><section id="block-1545677" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=200%2C45 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=300%2C68 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=400%2C91 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=540%2C123 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=750%2C171 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png?resize=1200%2C273 1200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/2724382e-3f2a-11e8-8a07-3bcdac0687a6.png 1700w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt="Argus-Press"></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1556880" class="tncms-block padding-bottom"><!--
Author: Tim Smith
-->
<style>
.date {color:#fff; font-weight:bold;}
@media (min-width:992px){
.date {text-align:right;}
}
</style>

<p class="date"></p>

<script>
var d=new Date();

var weekday = new Array(7);
weekday[0] =  "Sunday";
weekday[1] = "Monday";
weekday[2] = "Tuesday";
weekday[3] = "Wednesday";
weekday[4] = "Thursday";
weekday[5] = "Friday";
weekday[6] = "Saturday";

var n = weekday[d.getDay()];

var month = new Array();
month[0] = "January";
month[1] = "February";
month[2] = "March";
month[3] = "April";
month[4] = "May";
month[5] = "June";
month[6] = "July";
month[7] = "August";
month[8] = "September";
month[9] = "October";
month[10] = "November";
month[11] = "December";
var m = month[d.getMonth()];

var date = d.getDate();
var year = d.getFullYear();

function addZero(i) {
    if (i < 10) {
        i = "0" + i;
    }
    else if (i > 12) {
        i = i - 12;
    }
    return i;
}

    var h = addZero(d.getHours());
    var min = addZero(d.getMinutes());
    var ampm;
    if (d.getHours() > 12) {
    	ampm = "PM";
    }
    else {
    	ampm = "AM";
    }
    var time = h + ":" + min + " " + ampm;


/*$(".date").text(n + ", " + m + " " + date + ", " + year + " " + time);*/
$(".date").text(`${m} ${date} ${year}`);
    
</script></div><div id="tncms-block-1545731" class="tncms-block"><div id="weather-1545731" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=48867" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-cloudy"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">70&deg;</span>
                    
                        <span class="cond">Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li>
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="48867"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1545731 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Owosso, MI
                                
                                 <small>(48867)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>A mix of clouds and sun. High around 80F. Winds WNW at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Some clouds. Low 59F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: July 30, 2019 @ 9:40 am</small></p>
                        </div>
                    </li>
                    <li role="presentation" class="divider"></li>
                    <li class="forecast-link text-center"><a href="/weather/?weather_zip=48867"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop  navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1545722" class="tncms-block"><section id="block-1545722" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=200%2C45 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=300%2C68 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=400%2C91 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=540%2C123 540w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=750%2C171 750w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png?resize=1200%2C273 1200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/custom/image/f4e86d28-3f31-11e8-ad62-c7cefab62ee6.png 1700w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt="Argus-Press"></a></div></section></div><div id="tncms-block-1642447" class="tncms-block padding-bottom hidden-lg hidden-md"><!--
Author: Tim Smith
-->
<style>
.date {color:#fff; font-weight:bold;}
@media (min-width:992px){
.date {text-align:right;}
}
</style>

<p class="date"></p>

<script>
var d=new Date();

var weekday = new Array(7);
weekday[0] =  "Sunday";
weekday[1] = "Monday";
weekday[2] = "Tuesday";
weekday[3] = "Wednesday";
weekday[4] = "Thursday";
weekday[5] = "Friday";
weekday[6] = "Saturday";

var n = weekday[d.getDay()];

var month = new Array();
month[0] = "January";
month[1] = "February";
month[2] = "March";
month[3] = "April";
month[4] = "May";
month[5] = "June";
month[6] = "July";
month[7] = "August";
month[8] = "September";
month[9] = "October";
month[10] = "November";
month[11] = "December";
var m = month[d.getMonth()];

var date = d.getDate();
var year = d.getFullYear();

function addZero(i) {
    if (i < 10) {
        i = "0" + i;
    }
    else if (i > 12) {
        i = i - 12;
    }
    return i;
}

    var h = addZero(d.getHours());
    var min = addZero(d.getMinutes());
    var ampm;
    if (d.getHours() > 12) {
    	ampm = "PM";
    }
    else {
    	ampm = "AM";
    }
    var time = h + ":" + min + " " + ampm;


/*$(".date").text(n + ", " + m + " " + date + ", " + year + " " + time);*/
$(".date").text(`${m} ${date} ${year}`);
    
</script></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1545729" class="tncms-block"><div id="user-controls-1545729" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.argus-press.com/users/signup/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.argus-press.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-1545729').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.argus-press.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.argus-press.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.argus-press.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1545729').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.argus-press.com/users/logout/" id="user-logout-form-1545729"><input type="hidden" name="referer_url" value="https://www.argus-press.com/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newspapers-in-education"  href="/site/nie.html" >
                    <span class="nav-label">Newspapers in Education</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-forms"  href="/site/forms/" >
                    <span class="nav-label">Online Forms</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/news_local/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-news"  href="/news/news_local/" >
                    <span class="nav-label">Local News</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/news/community/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-2-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-owosso"  href="/news/community/owosso/" >
                    <span class="nav-label">Owosso</span>
                </a></li><li>
                <a class="nav-link  tnt-section-corunna"  href="/news/community/corunna/" >
                    <span class="nav-label">Corunna</span>
                </a></li><li>
                <a class="nav-link  tnt-section-durand"  href="/news/community/durand/" >
                    <span class="nav-label">Durand</span>
                </a></li><li>
                <a class="nav-link  tnt-section-perry"  href="/news/community/perry/" >
                    <span class="nav-label">Perry</span>
                </a></li><li>
                <a class="nav-link  tnt-section-morrice"  href="/news/community/morrice/" >
                    <span class="nav-label">Morrice</span>
                </a></li><li>
                <a class="nav-link  tnt-section-new-lothrop"  href="/news/community/new_lothrop/" >
                    <span class="nav-label">New Lothrop</span>
                </a></li><li>
                <a class="nav-link  tnt-section-byron"  href="/news/community/byron/" >
                    <span class="nav-label">Byron</span>
                </a></li><li>
                <a class="nav-link  tnt-section-laingsburg"  href="/news/community/laingsburg/" >
                    <span class="nav-label">Laingsburg</span>
                </a></li><li>
                <a class="nav-link  tnt-section-shiawassee-area"  href="/news/community/shiawassee_area/" >
                    <span class="nav-label">Shiawassee Area</span>
                </a></li><li>
                <a class="nav-link  tnt-section-chesaning"  href="/news/community/chesaning/" >
                    <span class="nav-label">Chesaning</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ovid"  href="/news/community/ovid/" >
                    <span class="nav-label">Ovid</span>
                </a></li><li>
                <a class="nav-link  tnt-section-elsie"  href="/news/community/elsie/" >
                    <span class="nav-label">Elsie</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-state-news"  href="/world_news/state_news/" >
                    <span class="nav-label">State News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national-news"  href="/world_news/national/" >
                    <span class="nav-label">National News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-international-news"  href="/world_news/international/" >
                    <span class="nav-label">International News</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/sports_local/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-by-school"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/by_school/" >
                    
                        <span class=""></span>
                    <span class="nav-label">By School</span>
                </a><ul id="main-nav_menu-child-3-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-byron"  href="/sports/by_school/byron/" >
                    <span class="nav-label">byron</span>
                </a></li><li>
                <a class="nav-link  tnt-section-chesaning"  href="/sports/by_school/chesaning/" >
                    <span class="nav-label">chesaning</span>
                </a></li><li>
                <a class="nav-link  tnt-section-corunna"  href="/sports/by_school/corunna/" >
                    <span class="nav-label">corunna</span>
                </a></li><li>
                <a class="nav-link  tnt-section-durand"  href="/sports/by_school/durand/" >
                    <span class="nav-label">durand</span>
                </a></li><li>
                <a class="nav-link  tnt-section-laingsburg"  href="/sports/by_school/laingsburg/" >
                    <span class="nav-label">laingsburg</span>
                </a></li><li>
                <a class="nav-link  tnt-section-morrice"  href="/sports/by_school/morrice/" >
                    <span class="nav-label">morrice</span>
                </a></li><li>
                <a class="nav-link  tnt-section-new_lothrop"  href="/sports/by_school/new_lothrop/" >
                    <span class="nav-label">new_lothrop</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ovid-elsie"  href="/sports/by_school/ovid-elsie/" >
                    <span class="nav-label">ovid-elsie</span>
                </a></li><li>
                <a class="nav-link  tnt-section-owosso"  href="/sports/by_school/owosso/" >
                    <span class="nav-label">owosso</span>
                </a></li><li>
                <a class="nav-link  tnt-section-perry"  href="/sports/by_school/perry/" >
                    <span class="nav-label">perry</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-by-sport"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/by_sport/" >
                    
                        <span class=""></span>
                    <span class="nav-label">By Sport</span>
                </a><ul id="main-nav_menu-child-3-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-auto_racing"  href="/sports/by_sport/auto_racing/" >
                    <span class="nav-label">auto_racing</span>
                </a></li><li>
                <a class="nav-link  tnt-section-baseball"  href="/sports/by_sport/baseball/" >
                    <span class="nav-label">baseball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-basketball"  href="/sports/by_sport/basketball/" >
                    <span class="nav-label">basketball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-bowling"  href="/sports/by_sport/bowling/" >
                    <span class="nav-label">bowling</span>
                </a></li><li>
                <a class="nav-link  tnt-section-competitive_cheer"  href="/sports/by_sport/competitive_cheer/" >
                    <span class="nav-label">competitive_cheer</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cross_country"  href="/sports/by_sport/cross_country/" >
                    <span class="nav-label">cross_country</span>
                </a></li><li>
                <a class="nav-link  tnt-section-football"  href="/sports/by_sport/football/" >
                    <span class="nav-label">football</span>
                </a></li><li>
                <a class="nav-link  tnt-section-golf"  href="/sports/by_sport/golf/" >
                    <span class="nav-label">golf</span>
                </a></li><li>
                <a class="nav-link  tnt-section-hockey"  href="/sports/by_sport/hockey/" >
                    <span class="nav-label">hockey</span>
                </a></li><li>
                <a class="nav-link  tnt-section-recreational_sports"  href="/sports/by_sport/recreational_sports/" >
                    <span class="nav-label">recreational_sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-soccer"  href="/sports/by_sport/soccer/" >
                    <span class="nav-label">soccer</span>
                </a></li><li>
                <a class="nav-link  tnt-section-softball"  href="/sports/by_sport/softball/" >
                    <span class="nav-label">softball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-swimming"  href="/sports/by_sport/swimming/" >
                    <span class="nav-label">swimming</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tennis"  href="/sports/by_sport/tennis/" >
                    <span class="nav-label">tennis</span>
                </a></li><li>
                <a class="nav-link  tnt-section-track"  href="/sports/by_sport/track/" >
                    <span class="nav-label">track</span>
                </a></li><li>
                <a class="nav-link  tnt-section-volleyball"  href="/sports/by_sport/volleyball/" >
                    <span class="nav-label">volleyball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wrestling"  href="/sports/by_sport/wrestling/" >
                    <span class="nav-label">wrestling</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-local-sports"  href="/sports/sports_local/" >
                    <span class="nav-label">Local Sports</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-national-sports"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/national/" >
                    
                        <span class=""></span>
                    <span class="nav-label">National Sports</span>
                </a><ul id="main-nav_menu-child-3-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-pistons"  href="/sports/national/pistons/" >
                    <span class="nav-label">Pistons</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tigers"  href="/sports/national/tigers/" >
                    <span class="nav-label">Tigers</span>
                </a></li><li>
                <a class="nav-link  tnt-section-lions"  href="/sports/national/lions/" >
                    <span class="nav-label">Lions</span>
                </a></li><li>
                <a class="nav-link  tnt-section-red-wings"  href="/sports/national/red_wings/" >
                    <span class="nav-label">Red Wings</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-college"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/national/college/" >
                    
                        <span class=""></span>
                    <span class="nav-label">College</span>
                </a><ul id="main-nav_menu-child-3-child-4-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-michigan"  href="/sports/national/college/u-m/" >
                    <span class="nav-label">Michigan</span>
                </a></li><li>
                <a class="nav-link  tnt-section-michigan-state"  href="/sports/national/college/msu/" >
                    <span class="nav-label">Michigan State</span>
                </a></li></ul></li></ul></li><li>
                <a class="nav-link  tnt-section-international-sports"  href="/sports/international/" >
                    <span class="nav-label">International Sports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-letters-to-the-editor"  href="/opinion/letters_to_editor/" >
                    <span class="nav-label">Letters To The Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-letter-to-editor"  href="/site/forms/online_services/letter/" >
                    <span class="nav-label">Submit Letter To Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-staff-commentaries"  href="/opinion/staff_commentaries/" >
                    <span class="nav-label">Staff Commentaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-guest-commentaries"  href="/opinion/guest_commentaries/" >
                    <span class="nav-label">Guest Commentaries</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-search-listings"  href="/classifieds/" >
                    <span class="nav-label">Search Listings</span>
                </a></li><li>
                <a class="nav-link  tnt-section-jobs"  href="/classifieds/job/" >
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cars"  href="/classifieds/vehicle/" >
                    <span class="nav-label">Cars</span>
                </a></li><li>
                <a class="nav-link  tnt-section-homes"  href="/classifieds/housing/" >
                    <span class="nav-label">Homes</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pets"  href="/classifieds/sale/pet/" >
                    <span class="nav-label">Pets</span>
                </a></li><li>
                <a class="nav-link  tnt-section-miscellaneous"  href="/classifieds/other/" >
                    <span class="nav-label">Miscellaneous</span>
                </a></li><li>
                <a class="nav-link  tnt-section-apartments"  href="/classifieds/housing/rent/apartment/" >
                    <span class="nav-label">Apartments</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-more"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">More</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-business"  href="/business/" >
                    <span class="nav-label">Local Business</span>
                </a></li><li>
                <a class="nav-link  tnt-section-education"  href="/education/" >
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link  tnt-section-health"  href="/health" >
                    <span class="nav-label">Health</span>
                </a></li><li>
                <a class="nav-link  tnt-section-arts-entertainment"  href="/arts_and_entertainment/" >
                    <span class="nav-label">Arts & Entertainment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-religion"  href="/religion/" >
                    <span class="nav-label">Religion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-kids-korner"  href="/kids_korner/" >
                    <span class="nav-label">Kids Korner</span>
                </a></li><li>
                <a class="nav-link  tnt-section-farm-garden"  href="/farm_garden/" >
                    <span class="nav-label">Farm Garden</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-neighbors"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/announcements/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Neighbors</span>
                </a><ul id="main-nav_menu-child-7-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-anniversaries"  href="/announcements/anniversaries/" >
                    <span class="nav-label">Anniversaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-births"  href="/announcements/births/" >
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link  tnt-section-engagements"  href="/announcements/engagements/" >
                    <span class="nav-label">Engagements</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weddings"  href="/announcements/weddings/" >
                    <span class="nav-label">Weddings</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link  tnt-section-legal-notices"  href="/legal_notices/" >
                    <span class="nav-label">Legal Notices</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1545619" class="tncms-block hidden-lg">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546651" class="tncms-block hidden-lg">
        <div id="blox-ad-position-block-leaderboard-middle-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-middle-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1674198" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-center-middle-one1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle-one","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546650" class="tncms-block hidden-xs hidden-sm col-md-8 col-lg-9">
        <div id="blox-ad-position-block-leaderboard-middle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-middle","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546655" class="tncms-block hidden-xs hidden-sm col-md-4 col-lg-3">
        <div id="blox-ad-position-block-tile-middle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-middle","slot":"1","fold":"above","width":"200","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546656" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-pencil1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-pencil","slot":"1","fold":"above","width":"960","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div id="modal-image-e91b8714-66e7-5a73-a862-26a7a7e5822d" class="modal fullscreen in modal-image image-default modal-e91b8714-66e7-5a73-a862-26a7a7e5822d" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=400%2C580"
                    srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=200%2C290 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=300%2C435 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=400%2C580 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=425%2C616 540w"
                    sizes="100vw"
                    width="425"
                    height="616"
                    alt="Deanna G. Springs"
                    class="img-responsive true-size" />
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-e91b8714-66e7-5a73-a862-26a7a7e5822d" data-target=".caption-inner-modal-image-e91b8714-66e7-5a73-a862-26a7a7e5822d">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-e91b8714-66e7-5a73-a862-26a7a7e5822d collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Fimage_e91b8714-66e7-5a73-a862-26a7a7e5822d.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/image_e91b8714-66e7-5a73-a862-26a7a7e5822d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":e91b8714-66e7-5a73-a862-26a7a7e5822d}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Deanna%20G.%20Springs&via=arguspress&url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Fimage_e91b8714-66e7-5a73-a862-26a7a7e5822d.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/image_e91b8714-66e7-5a73-a862-26a7a7e5822d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":e91b8714-66e7-5a73-a862-26a7a7e5822d}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.argus-press.com/tncms/asset/editorial/e91b8714-66e7-5a73-a862-26a7a7e5822d" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":e91b8714-66e7-5a73-a862-26a7a7e5822d}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Argus-Press%5D%20Deanna%20G.%20Springs&body=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Fimage_e91b8714-66e7-5a73-a862-26a7a7e5822d.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":e91b8714-66e7-5a73-a862-26a7a7e5822d}'  bSendHash rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/image_e91b8714-66e7-5a73-a862-26a7a7e5822d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":e91b8714-66e7-5a73-a862-26a7a7e5822d}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-e91b8714-66e7-5a73-a862-26a7a7e5822d-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e91b8714-66e7-5a73-a862-26a7a7e5822d" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e91b8714-66e7-5a73-a862-26a7a7e5822d" class="save-list-e91b8714-66e7-5a73-a862-26a7a7e5822d-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e91b8714-66e7-5a73-a862-26a7a7e5822d" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-e91b8714-66e7-5a73-a862-26a7a7e5822d img { max-height: 616px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="asset article-default"  data-url="https://www.argus-press.com/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=425%2C616">
            <meta itemprop="width" content="425">
            <meta itemprop="height" content="616">
        </div>
        <meta itemprop="name" content="argus-press.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.argus-press.com/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html" />
    <div class="asset-paging-container hidden-print">
            <div id="asset-paging-7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="asset-paging">
                <div id="paging-prev-7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="paging-link prev offset"></div>
                <div id="paging-next-7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <script>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</script><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Deanna G. Springs
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li>
        <time datetime="2019-07-29T11:00:00-04:00" class="tnt-date asset-date text-muted">23 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2019-07-29T11:00:00-04:00">
    <meta itemprop="datePublished" content="2019-07-29T11:00:00-04:00">
    <meta itemprop="dateModified" content="2019-07-29T11:00:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}' >    
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Deanna%20G.%20Springs&via=arguspress&url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.argus-press.com/tncms/asset/editorial/7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Argus-Press%5D%20Deanna%20G.%20Springs&body=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  bSendHash rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div id="asset-photo" class="card"><figure class="photo layout-vertical hover-expand"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-e91b8714-66e7-5a73-a862-26a7a7e5822d" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-e91b8714-66e7-5a73-a862-26a7a7e5822d" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="425">
            <meta itemprop="height" content="616">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=400%2C580"
                    srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=200%2C290 200w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=300%2C435 300w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=400%2C580 400w, https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/91/e91b8714-66e7-5a73-a862-26a7a7e5822d/5d3f06839426d.image.jpg?resize=425%2C616 540w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="425"
                    height="616"
                    alt="Deanna G. Springs"
                    class="img-responsive  letterbox tnt-restrict-img-e91b8714-66e7-5a73-a862-26a7a7e5822d" />
            </div><style>
                .tnt-restrict-img-e91b8714-66e7-5a73-a862-26a7a7e5822d {
                    max-width: 425px;
                }
            </style>
                
            </div>
            
                
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"><div id="tncms-block-1674197" class="tncms-block visible-sm visible-xs hidden-md hidden-lg">
        <div id="blox-ad-position-block-center-middle2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle","slot":"2","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1674200" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-center-middle-one1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-center-middle-one","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>

            <div id="asset-content" data-asset-uuid="7f67ce45-bc64-5ced-94d4-44d93d2b93e4">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Deanna%20G.%20Springs&via=arguspress&url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.argus-press.com/tncms/asset/editorial/7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Argus-Press%5D%20Deanna%20G.%20Springs&body=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  bSendHash rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7f67ce45-bc64-5ced-94d4-44d93d2b93e4-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="save-list-7f67ce45-bc64-5ced-94d4-44d93d2b93e4-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>Age 82, of Durand, passed away Saturday, July 27, 2019, at her home.</p></div><div class="subscriber-preview"><p>A memorial service will be set at a later date.</p></div><div class="subscriber-only"><p>Deanna Perkins was born May 24, 1937, in Henderson, a daughter of Harold and Ella (Casteel) Perkins. On June 1, 1963, she married James Springs.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>Deanna enjoyed traveling, playing dominos, making deserts, plants, flowers and taking pictures. Prior to her retirement, she cleaned for Dr. Jones’ office for 19 years, volunteered at Durand Union Station, Toys for Tots, at the Salvation Army, blood drives — she was a 20-gallon donor — and 20 years for the DVA.</p></div><div class="subscriber-only"><p>Deanna is survived by her husband James Springs, son Doug (Heather) Springs, granddaughters Abigail and Emily, and great-granddaughter Natalie.</p></div><div class="subscriber-only"><p>She was preceded in death by both of her parents.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle-asset', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>A special thank you would like to go out from the family to Katrina Dieck for all of her help and support.</p></div><div class="subscriber-only"><p>Memorial Contributions in Deanna’s name are suggested to the Durand Senior and Rehab Center.</p></div><div class="subscriber-only"><p>Online condolences may be sent at <a href="http://watkinsfuneralhomes.com">watkinsfuneralhomes.com</a>.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom-asset', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>
                            
                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Deanna%20G.%20Springs&via=arguspress&url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.argus-press.com/tncms/asset/editorial/7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Argus-Press%5D%20Deanna%20G.%20Springs&body=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  bSendHash rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":7f67ce45-bc64-5ced-94d4-44d93d2b93e4}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7f67ce45-bc64-5ced-94d4-44d93d2b93e4-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" class="save-list-7f67ce45-bc64-5ced-94d4-44d93d2b93e4-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div class="asset-recommend taboola hidden-print"><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails"></div><div id="taboola-below-article-text-links"></div></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/obituaries/article_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="7f67ce45-bc64-5ced-94d4-44d93d2b93e4" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom  usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.argus-press.com/users/login/?referer_url=https%3A%2F%2Fwww.argus-press.com%2Fobituaries%2Farticle_7f67ce45-bc64-5ced-94d4-44d93d2b93e4.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1587278" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-first1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-first","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584002" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-second1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-second","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584003" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-third1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-third","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586964" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-top-fourth1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-top-fourth","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1546640" class="tncms-block"><section id="block-1546640" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1546640 ">
        <div class="block-title-inner">
            <h3>
                
                Sign up for our E-mail Lists
                
            </h3>
        </div>
    </div></div><div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        
            <div class="mailinglist-container">
                <div class="form-group ">
                    
                        <div class="mailinglist-item">
                            <h4 class="mailinglist-title">Breaking News</h4>
                            
                                <p>The top headlines of the day- sent right to your email!</p>
                            
                        </div>
                    
                        <div class="mailinglist-item">
                            <h4 class="mailinglist-title">News Updates</h4>
                            
                                <p><span>Would you like to receive our daily news?&nbsp;</span><strong>Signup today!</strong><span>&nbsp;</span></p>
                            
                        </div>
                    
                </div>
                <div class="form-group">
                    <a href="https://www.argus-press.com/users/admin/mailinglist/" class="btn btn-default btn-block">Manage your lists</a>
                </div>
            </div>
        
    </div></div>
        </div></div></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1587277" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-first1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-first","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584004" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-second1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-second","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1584005" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-third1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-third","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586967" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-middle-fourth1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-middle-fourth","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1545629" class="tncms-block"></div><div id="tncms-block-1545678" class="tncms-block"><section id="block-1545678" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1545678 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1545678" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1545678" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1545678" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1545678" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1545678" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news_local/article_ce3bc5b4-ae1e-11e9-a60a-b74a5c96bf14.html">Owosso native nearly killed in Lansing attack has guardianship extended</a></li><li><a href="/news_local/article_e76896b8-b079-11e9-9ca0-ab80bd76faac.html">Top of her class</a></li><li><a href="/news_local/article_4e0e974c-afb1-11e9-b2e5-cba81562d60c.html">Fun and games</a></li><li><a href="/news_local/article_60a8fb7a-afe0-11e9-8c96-27d53f103627.html">Clark sentenced to over 13 years in prison for kidnapping</a></li><li><a href="/news_local/article_da42f22c-afb0-11e9-b58b-bb8908712a68.html">Duncan headed to trial Tuesday, questions arise with evidence collected at crime scene</a></li><li><a href="/news_local/article_94b7a33c-afb1-11e9-b37a-f732ff5691bd.html">Owosso man who hit, killed motorcyclist accepts plea deal</a></li><li><a href="/news_local/article_83f5e71e-ae1e-11e9-8727-afc94d87149a.html">Council Conflict</a></li><li><a href="/news_local/article_f4d44d4a-aee6-11e9-a56e-db3833c2fbcc.html">A quiet place</a></li><li><a href="/news_local/article_de1abaec-ad53-11e9-97c4-fbebe1097dfd.html">Owosso man narrowly avoids prison term for drug possession</a></li><li><a href="/news/news_local/article_1cab7561-4d57-52b3-aec9-48d0266693c8.html">Elsie woman sentenced to prison for meth</a></li></ul></div>
        
        
            <div id="images-1545678" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/sports/image_4fecad54-a89c-11e9-b68f-1b5b3aca54cd.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="2019 champs"
                        class="img-responsive lazyload full"
                        width="1221"
                        height="1221"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/4/fe/4fecad54-a89c-11e9-b68f-1b5b3aca54cd/5d2f2c7702e00.image.jpg?crop=1221%2C1221%2C0%2C238&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/news/news_local/image_9666e250-3d5b-5be3-b957-72ade049003d.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Cooling Off"
                        class="img-responsive lazyload full"
                        width="425"
                        height="425"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/9/66/9666e250-3d5b-5be3-b957-72ade049003d/5d325d186176c.image.jpg?crop=425%2C425%2C107%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/world_sports/image_4a81fe49-39a4-5021-bb64-50c1fc50b14d.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="1 forecast shows US topping medal table at Tokyo Olympics"
                        class="img-responsive lazyload ap-photo full"
                        width="1091"
                        height="1091"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/4/a8/4a81fe49-39a4-5021-bb64-50c1fc50b14d/5d36ab4e92ebb.image.jpg?crop=1091%2C1091%2C404%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/news/international/image_68adeaae-7c47-5992-adb0-3c811b1815b9.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Beethoven tras las rejas: Perú rehabilita presos con música"
                        class="img-responsive lazyload ap-photo full"
                        width="1182"
                        height="1182"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/6/8a/68adeaae-7c47-5992-adb0-3c811b1815b9/5d38b9373b5fd.image.jpg?crop=1182%2C1182%2C286%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/world_sports/image_2631b55b-4711-56b6-98f8-aeda119606bc.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Boca vence a Paranaense con gol del debutante Mac Allister"
                        class="img-responsive lazyload ap-photo full"
                        width="1191"
                        height="1191"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/63/2631b55b-4711-56b6-98f8-aeda119606bc/5d391f1db4371.image.jpg?crop=1191%2C1191%2C274%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/news/news_local/image_db2c5add-fa66-52b0-9967-0ea65e9e18c4.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="NEW FINANCE DIRECTOR"
                        class="img-responsive lazyload full"
                        width="624"
                        height="624"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/b2/db2c5add-fa66-52b0-9967-0ea65e9e18c4/5d2f34826b48e.image.jpg?crop=624%2C624%2C8%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/arts/entertainment/image_fa0e97d5-10b9-566f-8ef0-25b778e1f82e.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Westwind rocks amphitheater"
                        class="img-responsive lazyload full"
                        width="540"
                        height="540"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/f/a0/fa0e97d5-10b9-566f-8ef0-25b778e1f82e/5d31d772b53ba.image.jpg?crop=540%2C540%2C50%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/arts/entertainment/image_2306c4aa-5db3-5f58-9645-a3995e4949f4.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="CLASSICS ON DISPLAY"
                        class="img-responsive lazyload full"
                        width="480"
                        height="480"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/2/30/2306c4aa-5db3-5f58-9645-a3995e4949f4/5d2c94f42b2f8.image.jpg?crop=480%2C480%2C80%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/world_sports/image_d86a5339-0d5d-5c7a-9914-f8b25d1c299f.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Monumental comedor asombra en Villa Panamericana de Lima"
                        class="img-responsive lazyload ap-photo full"
                        width="1175"
                        height="1175"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/86/d86a5339-0d5d-5c7a-9914-f8b25d1c299f/5d3a516edcdb8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1545678" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-1545678" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/opinion/letters_to_editor/article_0755a57f-e31d-5072-914b-d162a9d9315e.html">Trump’s Persian Gulf comments provide eerie reflection</a> (2)</li><li><a href="/opinion/letters_to_editor/article_0e0c7fb8-aee6-11e9-8f38-1f411e367743.html">Guardianship taking every cent from Bob Neil</a> (2)</li><li><a href="/opinion/letters_to_editor/article_2c801e92-aa2d-59a0-9495-233d36ebbebc.html">Silence from Moolenaar on Trump’s racist comments</a> (2)</li><li><a href="/opinion/letters_to_editor/article_3b8fbfa5-0283-5e2a-b19c-bac628c7cfb9.html">Pressley espoused racist views, why not attack her?</a> (2)</li><li><a href="/opinion/letters_to_editor/article_a95e52b9-1081-5680-bdf9-52dac5b27799.html">Trump critic off the mark yet again</a> (2)</li><li><a href="/opinion/letters_to_editor/article_0ce4c188-b079-11e9-97b8-438ca6ffd030.html">There is no such thing as 'can't'</a> (1)</li><li><a href="/news/news_local/article_14ab2b5f-a852-53ef-b3c7-50c7fb94112d.html">Officials, police officers support former Oakley chief</a> (1)</li><li><a href="/world_sports/article_2889d9c4-d19c-59b2-ae88-7e08d614e439.html">Delle Donne teams up with PETA in ad campaign</a> (1)</li><li><a href="/opinion/letters_to_editor/article_3233c996-3959-5408-8bed-331178109c71.html">Writer attacks president without facts</a> (1)</li><li><a href="/opinion/letters_to_editor/article_3c02de8a-aee6-11e9-b8ba-f3ce8145d42d.html">What do you think of the Mueller Report?</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-1545661" class="tncms-block"><section id="block-1545661" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1545661 ">
        <div class="block-title-inner">
            <h3>
                
                Online Poll
                
            </h3>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/poll_d9a5216a-b216-11e9-a9fc-1fb6e77631a7.html" class="tnt-asset-link">
        

        
            Did Robert Mueller's televised testimony sway your opinion on Trump at all?</a></h4>
            <div id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-your-vote"></span>
                </div>
                <div id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-results" class="tnt-poll-results hide"></div>
                <div id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-container">
                    <form id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-form" class="tnt-poll-form" role="form" method="post" action="/poll_d9a5216a-b216-11e9-a9fc-1fb6e77631a7.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="No, he still needs to be impeached" value="C88A4286-A200-0001-35A3144E19EBC650"> No, he still needs to be impeached
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="No, I still don't think he did anything wrong" value="C88A4288-A190-0001-AAAB4A60182019D9"> No, I still don't think he did anything wrong
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Yes, I think he broke the law" value="C88A428B-19F0-0001-41DC1EB0EB8021B0"> Yes, I think he broke the law
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Yes, I think he is innocent" value="C88A428C-E570-0001-3EB09220166718A8"> Yes, I think he is innocent
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="I didn't watch" value="C88A4297-8100-0001-CE2913C0BBE01AA6"> I didn't watch
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-back-vote" class="padding-top hide">
                <button id="poll-d9a5216a-b216-11e9-a9fc-1fb6e77631a7-1545661-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div><div id="tncms-block-1546647" class="tncms-block"><section id="block-1546647" class="block emphasis-h3    tnt-no-margin-bottom tnt-has-block-bg" ><div class="clearfix">
    
    <div class="block-title title-1546647 ">
        <div class="block-title-inner">
            <h3>
                
                Find more information
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-1546647-1ac77ab0-0d18-11e0-b4b6-001cc4c002e0" class="clearfix card summary inherit ">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.chesaningschools.net" class="tnt-asset-link">
        

        
            Chesaning Union Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-b9c05fe8-0d17-11e0-a264-001cc4c002e0" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-b9c05fe8-0d17-11e0-a264-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-vertical">
            <div class="image" 
                >
                
                    <a href="http://www.laingsburg.k12.mi.us/" class="tnt-asset-link">
                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Laingsburg Community Schools"
                    class="img-responsive lazyload  letterbox"
                    width="100"
                    height="103"
                    data-src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/b/9c/b9c05fe8-0d17-11e0-a264-001cc4c002e0/5abe6b5d2719f.preview.jpg" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.laingsburg.k12.mi.us/" class="tnt-asset-link">
        

        
            Laingsburg Community Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-c9b5bd8a-0d17-11e0-89c1-001cc4c002e0" class="clearfix card summary inherit ">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.morrice.k12.mi.us/" class="tnt-asset-link">
        

        
            Morrice Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-df18cca8-0d17-11e0-a274-001cc4c002e0" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-df18cca8-0d17-11e0-a274-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="http://byron.k12.mi.us/" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Byron Area Schools"
                        class="img-responsive lazyload full"
                        width="100"
                        height="100"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/d/f1/df18cca8-0d17-11e0-a274-001cc4c002e0/5abe813b2eb4e.preview.jpg?resize=100%2C100" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://byron.k12.mi.us/" class="tnt-asset-link">
        

        
            Byron Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-edd711f0-0d17-11e0-85e4-001cc4c002e0" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-edd711f0-0d17-11e0-85e4-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-vertical">
            <div class="image" 
                >
                
                    <a href="http://www.newlothrop.k12.mi.us/" class="tnt-asset-link">
                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="New Lothrop Area Schools"
                    class="img-responsive lazyload  letterbox"
                    width="100"
                    height="112"
                    data-src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/dd/edd711f0-0d17-11e0-85e4-001cc4c002e0/5abe8157ed71c.preview.jpg" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.newlothrop.k12.mi.us/" class="tnt-asset-link">
        

        
            New Lothrop Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-033f698a-0d17-11e0-a164-001cc4c002e0" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-033f698a-0d17-11e0-a164-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="http://www.corunna.k12.mi.us/" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Corunna Public Schools"
                        class="img-responsive lazyload full"
                        width="100"
                        height="100"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/0/33/033f698a-0d17-11e0-a164-001cc4c002e0/5abe8180ac722.preview.jpg?resize=100%2C100" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.corunna.k12.mi.us/" class="tnt-asset-link">
        

        
            Corunna Public Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-55b0914e-0d17-11e0-a176-001cc4c002e0" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-55b0914e-0d17-11e0-a176-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="http://www.durand.k12.mi.us/" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Durand Area Schools"
                        class="img-responsive lazyload full"
                        width="100"
                        height="95"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/5/5b/55b0914e-0d17-11e0-a176-001cc4c002e0/5abe81b6436da.preview.gif?resize=100%2C95" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.durand.k12.mi.us/" class="tnt-asset-link">
        

        
            Durand Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-9b0881f2-0d17-11e0-a2d9-001cc4c002e0" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-9b0881f2-0d17-11e0-a2d9-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="http://www.perry.k12.mi.us/" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Perry Public Schools"
                        class="img-responsive lazyload full"
                        width="100"
                        height="71"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/9/b0/9b0881f2-0d17-11e0-a2d9-001cc4c002e0/5abe81dbaf2e3.preview.jpg?resize=100%2C71" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.perry.k12.mi.us/" class="tnt-asset-link">
        

        
            Perry Public Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-e8b908aa-0d16-11e0-b308-001cc4c002e0" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-e8b908aa-0d16-11e0-b308-001cc4c002e0 media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="http://www.owosso.k12.mi.us/" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Owosso Public Schools"
                        class="img-responsive lazyload full"
                        width="100"
                        height="92"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/e/8b/e8b908aa-0d16-11e0-b308-001cc4c002e0/5abe81f768acb.preview.png?resize=100%2C92" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://www.owosso.k12.mi.us/" class="tnt-asset-link">
        

        
            Owosso Public Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1546647-ceb368a6-3c10-11e9-ab0f-6b039072eb4f" class="clearfix card summary has-image image-left inherit ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-ceb368a6-3c10-11e9-ab0f-6b039072eb4f media-preview image-asset" data-aspect="original"><figure class="photo layout-vertical">
            <div class="image" 
                >
                
                    <a href="/image_ceb368a6-3c10-11e9-ab0f-6b039072eb4f.html" class="tnt-asset-link">
                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Ovid-Elsie Area Schools"
                    class="img-responsive lazyload  letterbox"
                    width="1067"
                    height="1079"
                    data-src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/content/tncms/assets/v3/editorial/c/eb/ceb368a6-3c10-11e9-ab0f-6b039072eb4f/5c7910199faf6.image.jpg?resize=200%2C202" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/image_ceb368a6-3c10-11e9-ab0f-6b039072eb4f.html" class="tnt-asset-link">
        

        
            Ovid-Elsie Area Schools</a></h3></div>
                    
                    
                    
                    
                        
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div><span class="clearfix"></span></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1587276" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-first1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-first","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586968" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-second1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-second","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586969" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-third1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-third","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586970" class="tncms-block visible-md visible-lg">
        <div id="blox-ad-position-block-right-rail-bottom-fourth1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail-bottom-fourth","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>



        <div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1545620" class="tncms-block hidden-xs hidden-sm col-md-8 col-lg-9">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1586965" class="tncms-block hidden-xs hidden-sm col-md-4 col-lg-3">
        <div id="blox-ad-position-block-tile-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-bottom","slot":"1","fold":"above","width":"200","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1545718" class="tncms-block"><section id="block-1545718" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1545718 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-business"  href="/business/" >
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photo-gallery"  href="/gallery/" >
                    <span class="nav-label">Photo Gallery</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1545669" class="tncms-block"><section id="block-1545669" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1545669 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-forms"  href="/site/forms/" >
                    <span class="nav-label">Online Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="/site/forms/online_services/place_an_ad/" >
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link  tnt-section-email-alerts"  href="/users/admin/mailinglist" >
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1545720" class="tncms-block"><section id="block-1545720" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1545720 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>www.argus-press.com</strong><br>
    201 E. Exchange Street<br>
    Owosso, MI 48867
    <br>
    
        <strong>Phone:</strong> (989) 725-5136<br>
        <strong>Email:</strong> <a href="mailto:news@argus-press.com">news@argus-press.com</a><br>
    
</address></section></div><div id="tncms-block-1545728" class="tncms-block padding-bottom"><div class="follow-links-1545728 default">
    
    <section id="block-1545728" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/arguspress/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.argus-press.com",
  "sameAs" : ["http://facebook.com/pages/Owosso-MI/The-Argus-Press/227062489846","http://twitter.com/arguspress/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1545673" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1545673"><div class="col-md-7"><small>&copy; Copyright 2019 <a href="/">The Argus-Press</a>, 201 E. Exchange Street Owosso, MI</small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/argus-press.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div>
    <script>
window.__tnt || (window.__tnt = {});
__tnt.compatibility || (__tnt.compatibility = {});

__tnt.compatibility.status = "";
__tnt.compatibility.check = function(){
    var compatible = true;
    var status = "";

    if(typeof(__tnt.advertisements)=="undefined"){
        compatible = false;
        status += "FAIL: object 0 undefined "
    }

    __tnt.compatibility.status = status;
    return compatible;
}
__tnt.compatibility.notification = function(){
}

$(function(){
    if(!__tnt.compatibility.check()){
        if(window.ga){
            __tnt.trackEvent({'category':'subscription','action':'adblock','label':'adblock detected','value':'1'});
        }
        
        __tnt.compatibility.notification();
    }
});
</script>

    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if( jQuery.type(obj) === 'object' ){
                 
                    if(obj.category && obj.action){
                        __tnt.googleEvent(obj);
                    } else if(obj.network && obj.socialAction){
                        __tnt.googleSocial(obj);
                    } else if(obj.url){
                        __tnt.googlePageView(obj);
                    }
                    if(typeof TNCMS.Tracking != 'undefined' && obj.metric){
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
                
            }
        }
        
        if(__tnt.trackEventLater.length > 0){
            jQuery(__tnt.trackEventLater).each(function(){
                __tnt.trackEvent($(this));
            });
        }
        jQuery('body').on(__tnt.client.clickEvent, '[data-track]', function(){
            var trkObj = jQuery(this).data('track');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-event]', function(){
            var trkObj = jQuery(this).data('tncms-track-event');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-dmp]', function(){
            var dmpData = jQuery(this).data('tncms-track-dmp');
            });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.b98d49b697684d05ae0f8d0f1cc8bb9c.js"></script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1545730 = $('#user-controls-1545730 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1545730.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_1545730.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1545729 = $('#user-controls-1545729 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1545729.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_1545729.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ 
            window._taboola = window._taboola || [];
            _taboola.push({article:'auto'});
            !function (e, f, u, i) {
                if (!document.getElementById(i)){
                    e.async = 1;
                    e.src = u;
                    e.id = i;
                    f.parentNode.insertBefore(e, f);
                }
            }(document.createElement('script'),
            document.getElementsByTagName('script')[0],
                '//cdn.taboola.com/libtrc/townnews-network/loader.js',
                'tb_loader_script');
            if(window.performance && typeof window.performance.mark == 'function')
                {window.performance.mark('tbl_ic');}
        
                        window._taboola = window._taboola || [];
                        _taboola.push({
                            mode: 'thumbnails-a',
                            container: 'taboola-below-article-thumbnails',
                            placement: 'Below Article Thumbnails',
                            target_type: 'mix'
                        });
                    
                        window._taboola = window._taboola || [];
                        _taboola.push({
                            mode: 'hybrid-text-links-a',
                            container: 'taboola-below-article-text-links',
                            placement: 'Below Article Text Links',
                            target_type: 'mix'
                        });
                    
              window._taboola = window._taboola || [];
              _taboola.push({flush: true});
         /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.d623712c6b7d8bac4ef2995a9297b281.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/argus-press.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.0c07cc44c239ce8e6bb4e613f0c651fc.js"></script></body>
</html>